Jailbroken ATV2 won't boot

I ran Seas0nPass (latest version) last night on my Mac.  I’m running the latest iTunes and everything went successfully, however the ATV2 won’t boot.  I get the apple logo, then the screen goes to black and nothing ever happens.  I tried running through the Seas0nPass process a second time with the same result.  

Any suggestions or ideas?  I was going to try on a different Mac tonight but I don’t know why that would make any difference.

Thanks for any help! 

You do not mention doing a tethered boot?

The current jailbreak is tethered.    That means that any time power is removed (or you do a hard reset) you then have to connect the ATV2 to your PC/Mac that carried out the jailbreak via USB to carry out a tethered boot stage before the ATV2 can successfully boot.  Note that you do NOT repeat the iTunes stage where you did a restore when you do a tethered boot.

This is a real bummer.  Is an untethered jailbreak coming?  Since I didn’t save the signatures, there is no way to revert back to a lower version that supports an untethered jailbreak?

You guys should add some type of warning or something in Seas0nPass that gives you an explicit warning that this is tethered only.  Had i realized, I wouldn’t have “upgraded”.

do you mean a warning something like this? …

 

Seas0nPass provides a TETHERED jailbreak of the 2nd gen Apple TV running the latest 5.3 (iOS 6.1.4 - 10B809) software that was released on June 19th, 2013.

Older Apple TV versions can be used with saved firmware signatures.

The 3rd gen Apple TV is not yet supported.

I’m having the same problem as Jimm. So… itimpi, when I connect my mac to the ATV2 with a USB cable, what software am I supposed to run on the Mac to complete the tethered boot stage? SeasonPass or the ATV Flash (black) software? 

SeasonPass.

Make sure you use the tethered boot button - you do not want to repeat the full jailbreak process.