Jailbroken 4.4.4 ATV2 won't restart after reboot (itunes logo)

I have been using ATV2 4.4.4 jailbroken (untethered) perfectly for several weeks. Yesterday XBMC crashed and I had to restart the ATV by holding down both the MENU & PLAY/PAUSE buttons on the remote. After it rebooted the iTunes logo appeared and the LED flashes repeatedly. 

What can I do to get it back up and running with 4.4.4? 

Was this a thehered or untethered jailbreak of 4.4.4?

The symptoms you describe suggest a tethered jailbreak, and that the ATV2 is now waiting to be connected to your PC/Mac via USB to complete the tethered boot process.

I am sure it was an untethered. 

So does that mean I need to re-jailbreak it again using the guide with the SHSH stuff??

I just tried iFaith and it cannot detect the iOS version?

 

I think you can see the firmware with tinyumbrealla. Was having error with ifaith, got it with tinyumbrella.

i have tried using ifaith but it seems to be stuck in recoery mode. i have tried tiny umbrella but it cannot get the shsh whilst in recovery mode.

i have tried recboot.

i am trying to avoid having recovering to 5.1.  but unless somebody can help me, i am going to have to.

I have the same problem, from the same way you described.

Any joy?

is your led blinking? try connect atv to itunes and disconnect without restore. It shoud fix the issue.

I had this.

Just unplug the ATV from the mains and plug back in. Then Just wait. Should start up eventually.

Just keep trying.

Benano, I’m seeing the exact same issues with 5.0.1; upon upgrade I see that this has come up after a successful flash and cannot seem to get it to revert.  Any luck?

I am having the same issue with the ATV 5.0 but what i always do is to connect the usb to the ATV and let it boot tethered. although its a pain plugging the usb in and out with the season pass but it works after its done.