Jailbroken 4.3 Restore?

Hi, I have used Seas0nPass to jailbreak my new ATV2 and it worked… great tool. However, when I tried to save my shsh with iFaith it tells me that I have an unknown version of iOS. I think this is because the Seas0nPass jailbreak has changed my build number to (2557).

I just wanted to know if there is any other way to save my blobs, or if the .ipsw file seas0npass created is signed? So if I ever need to restore can I use that file even though Apple has stopped signing 4.3?

Thanks in advance for any help.

Bump. Anyone?

Use tiny umbrella to save your blobs.  Worked for me after my jailbreak. 

 

Thanks for the reply. I tried yesterday, but it fails - I don’t think Apple is still signing 4.3.

I did this yesterday on 2 new devices that had 4.3.  I will be doing another one today or tomorrow.  Are you currently on 4.3 now?  In your post it says you used iFaith and not tiny umbrella.  I believe (but I could be VERY wrong) that if you are currently running 4.3 you can backup your SHSH even if Apple is not signing it, the problem occurs if you are trying to downgrade, dont have your SHSH saved, AND Apple is not signing it.

Yes I’m on jailbroken 4.3 now. I tried iFaith and Tiny Umbrella. I will try Tiny Umbrella again though based on your comment.

No, you cannot backup your shsh if Apple is not signing them. The only way to get the current shsh off your device is using iFaith.

Whoa, you were right! Apple are still signing 4.3. Last time I had forgotten to untick the box for checking cydia. Thanks man!!