Was given a 1st gen apple tv,on boot it was running openelec unofficial version(5.95.5) architecture-ATV.1386 running kodi 15.1.I decided after some research online to reflash a apple restore image 3, this went okay and was able to restore to original state.which as you know is very limited so next flashed an external usb ssd with OSMC running kodi 17.3 was impressed with this set up but wanted to flash hard drive with same set up,so tried to flash OSMC onto system to replace apple os,used a trancend 8gig sd in adapter for job ,but failed on reeboot with the apple logo with question mark flashing above.Any how was stuck with this and could not reflash decided again to restore apple image back using img 3 again got to language page then factory restore failed so loaded image 2 which was the prev firmware version that loaded ok then when set up proceeded to update to version 3 so i am basically back to stage one.My question is this is it worth trying to jailbreak this version of apple tv if so any tips on crystal hd ,is it going to be supported in future any guidance would be very helpful as i am new to this game…Looking forward to any feedback…Rav

I actually went back to ATVFlash (silver) for this very reason because the latest build of OSMC does not support CrystalHD…
The best Kodi version for CrystalHD support is the build by Chewitt at http://chewitt.openelec.tv/appletv/

Update actually i tried again to load osmc onto my apple 1st gen,this time downloaded hard drive image using osmc software so now is running from apple instead of usb drive.But the only problem i have is cannot connect to internet wired but ok with wireless connection,if anyone has any tips to fix this problem,and any tips on replacing ide pata drive with a ssd drive that would be most welcome.