Jailbreaking Issue…. Have tried everything i've seen in forum. Help if you can

Hey guys,

I just purchased a brand new ATV2  with firmware 4.3 (2557) with the full intentions of Jailbreaking it.  Before i made the purchase i did tonnes of research and i made the leap.  While i have never jailbroken something before, i do have a substantial amount of computer knowledge, so i’m not completely incapable… but right now i’m feeling useless.  I started by downloading and installing tinyumbrella 5.00.12, most recent version of Seas0npass Version 0.7.8 (165) on my mac with the most recent itunes.  I started by saving the SHSH files and unchecking the 2 cydia boxes in umbrella.  I then went ahead and tried to jailbreak with seasonpass.  It first started coming up with the error saying that this device was not able to be restored to that version.  I also kept getting error 21, over and over again.  i eventually reinstalled the 4.3 firmware to see what would happen and it was able to restore it.  So this cancels out the cable issue that many of you talk about. I then tried the same thing using a windows xp computer.  I have tried using snOwbreeze, pwnage tool, and ireb to help with the dfu.  none the less i have tried everything that i have read in these forums to combat the 1600 error issue, the 3194 error, the 21 error.  I have turned off all my security protocols and programs, i have made sure that my atv2 was in dfu, i have tried it unteathered without power cables and with power cables.  as i already mentioned i unchecked the “set host to cydia on exit” and the other one.  I have restarted the computers and have tried multiple usb cables.  In terms of the USB cables they always pop up the itunes on install and are working to transfer data.  Even after failed attempts i would plug the atv to my tv and the micro-usb and itunes logo would show up meaning that the atv was either corrupted (due to the restores not properly happening or for being stuck in restore mode) but i have been able to restore it back to the original 4.3 with out issues every time. So this is where i now stand.  

So next on the to do list… well its still the first thing on the list, get the atv2 jailbroken… then buy and install the aTV flash black, and then live a happy life. :slight_smile:

 

Any and all help would be appreciated.  Without any exaggeration i have now put in about 20 hours of actual labour into getting the jailbreak to work, and only now am i resorting to asking for help.  

Vito

So i’ve noticed a few more things.  For starters, when I first plugged my atv to the comp and turned on Umbrella, it didn’t recognize the device.  just showed a numbered device that was in recovery mode.  To do anything i had to add it by adding a custom device using the manual ecid.  What i have now done (as i continue to try different things…  i have plugged in the hdmi cable which is plugged to the tv and then add the power cord.  once the apple logo appears on the tv i disconnect the hdmi and add the usb from the comp.  this then allows me to see the actual device with all the correct information in umbrella.

now my main issue is that i keep getting a 1600 error.  what i noticed in the umbrella log is that when i put the atv in dfu mode it only stays in that mode for a few milliseconds… 

10/17/2011 20:09:57.543 Device disconnected: Vito’s Apple tv

 10/17/2011 20:09:58.215 DFU Device connected

10/17/2011 20:09:58.348 DFU Device disconnected

 

Could this be the issue with 1600??? and if so how do i get around it… because apparently it doesn’t look like the atv2 is staying in dfu mode long enough for itunes to restore the custom firm.

 

 

Edit:

Go figures I was even able to downgrade it to 4.2.2, and now when i run seas0npass it says that the device isn’t elgible.  But if i turn on the tss server in umbrella and then try it it gives me the 1600 error…. also at the moment, i’m able to keep the atv2 in dfu mode… which helps of course

Edit Again:

So i went ahead and brought it back up to my original firm of 4.3.  But i still can’t get the jailbreak to work.  Once again, as long as i have tss server running on umbrella, i will get 1600 errors (tried playing with different settings in umbrella), but without the tss server on, i get the notification that this device is not eligible for that specific build (custom ipsw made via seas0npass)

 

HELP!!

A few tips for overcoming the various iTunes restore errors can be found here.

I appreciate your reply James.  But unlike most people i have gone over this forum, and many others trying to find a resolution, and have been to that thread you posted many times before posting.  As i said in my post, i’ve tried everything in that list of possibilities.  any other ideas would be great.  i’m just wondering if maybe the newest itunes has something to do with it?

Seems odd I jailbroke to atv’s yesterday on 4.3 I did get error messages but went ahead & tried atv flash which worked on both.

This may sound weird, but I kept getting failed restores while trying to jailbreak as well. iTunes would go through a bunch of the restore, but eventually just hang there and return an error.

I got it to work, by hooking up my power cable before and during the restore, and when it began to hang in the same place as the previous 4 attempts, I unplugged the power cable. It immediately finished the restore and I was good to go.

Shrug.

Tearing my hair out here. Just had one delivered today and I just can’t get it working.

 

Got the new Seasonpass 0.7.9 (230), done the unchecking with Tiny Umbrella but just constantly get either 1600, 2600 or 2900. Tried plugging it in, that led to 21.

 

I’m a vetaran jaibreaker and have about 50 tabs open here trying to get to the bottom of it but this has just defeated me now. Only wanted it for Plex but looks like I’ll just have to give up.

Similar problem - I’ve gotten it jailbroken once and into DFU mode, did the break and was getting an error 20, and now an error 1600. Did everything you’ve done too - it seems to be a general problem that Firecore really needs to address, aside from pointing us at an Apple page that renders no real help… 

If you haven’t already, you may try an alternate USB cable.

Surprisingly the type cable makes a huge difference.

A good, low cost cable can be found here. http://goo.gl/noOU2

SOLUTION! (err - not a solution. Seems to revert me back to iOS 4.3, now that I've checked the system. I'll leave this here in case people need to restore after updating to 4.4)

Okay - first, no...it wasn't the cable. I'm sure that there are cheap cables out there, but this "catch-all" answer wasn't a problem at all. 

I did an update to 4.4 literally minutes before Firecore sent out the mail... bloody hell. Updated, tried to re-jailbreak but also hit the 1600/20/21-error wall. I got past it and initially thought I updated to 4.4, but it seems it's only 4.3. Still, i got past the error and have a working unit again. 

Following the method on this page: 

http://support.firecore.com/entries/387605-jailbreaking-101-seas0npass#overview

The key missing thing was in the Jailbreaking methodology. The change comes in "Step 2: Select the 'Create IPSW' button to start the jailbreak process." 

When you're about to click the Create IPSW button, HOLD THE SHIFT KEY DOWN AND THEN CLICK

An additional file is added (I didn’t write it down - perhaps someone will follow-up on this) and then the process runs through iTunes without a problem. 

I’m sure you need to do all the things above, especially shutting-off Little Snitch and making sure Cydia isn’t in the hosts, but this extra step worked for me. 

Good luck out there…