Jailbreaking, I know, there are thread on this, but...

OK. I have read all posts on this subject and tried all the proposed solutions of which none worked. I have ATV 1 and ATV2. Jailbroke long time ago ATV1. Now trying to do the same for ATV2. Following instructions to the letter for jailbreaking ATV2. First issue, just connecting the ATV2 with a microUSB to my laptop (MacBook Pro - early 2011, Lion), I don’t get the flashing light. Unplug, plug, unplug, use different USP port on the laptop. No avail. The only way is to plug the power in, and use the silver remote to make it flash. Problem, SeaOnpass doesn’t see the ATV. Just stay, saying, waiting for… Fine. I used a different micro USB cable, just in case. Same results.

 

Hey, FireCore! I like you, I have trusted you in the past. WTF is going on now. Support, advice. Seems I am not the only with this issue.

 

Any solution?

My method to get the device into DFU has worked flawlessly for me for all the aTV2 devices I have jailbroken. The process I went through is to connect the USB cable to the computer (leaving the other end disconnected from the Apple TV). On the Silver Remote holding Menu and Play/Pause. Continue holding them and plug the Micro USB into the Apple TV. Continue holding the buttons for 7 seconds. The device should be in DFU mode to allow Seas0nPass to restore it.

Again this is the method I use and it works 100% of the time for me.

I’m having the same EXACT issue.  Bought new Monster micro usb cable, and everything. Still says waiting for device in dfu mode.  Have written firecore and haven’t gotten any help at all… Where are you guys (firecore) w the support?!

 

You’re going to need to provide more information. First off are you on a Windows based computer or a Mac?

If you are on a Windows based computer download and the application called USBVIEW.EXE. This will allow you to see if you are in Normal/Recovery/DFU mode.

I’m using a Unibody Macbook 2009.  Latest version of itunes and all relevant software updates.  I’ve tried three micro usb cables (including the one I bought today), and tried it with multiple USB ports.  With each cable and USB port itunes recognizes the ATV and is able to restore it, so I’m pretty sure it’s not the cables.  I actually have even tried it on my wife’s macbook (black version prior to unibody) and no luck whatsoever.  This is my second time trying this for about 4-5 hrs and it’s not working.  ANy help would be greatly appreciated.   

 

Looks like otisb.7407 an me are both on Mac platform (in my case an Early 2011 MacBook Pro w/Lion), so your solution cannot relate to our case. Thanks anyway, it is appreciated.

 

EDIT: I also tried with an iMac (2011) running OSX 10.6 with no results. Previously, I was running Lion (10.7) on a MacBook Pro.