Jailbreaking ATV2 Running 5.0.1 or Less, After Apple Stopped Signing Older Firmware Versions

All I know is that it worked for me.

Just slightly updated the guide to clarify a few things, hope it helps.

Stuck at the first step : downloading essentials in iFaith since 1h, nothing happen.

Wow, this worked like a charm. After spending two days for my new apple TV which came with software version 4.2.1, this was the only thing that worked. Very straight forward. I can confirm that it works for iOS 4.3. Thanks a lot.

Good for you :wink:

In my case, I cannot retrieve the SHSH blobs from my atv2.

same problem here i hare 2 apple tv’s 2gen! one is 5.0 (4099) and 4.4.4 jailbreak

and both same problem unknow os detected!

I’ve posted this on the JBATV2 forum as well, but so far no responses. I followed the instructions but couldn’t get past Part 1, Step 1. When I try to launch iFaith, I get an application error message: "The application failed to initialize properly (0xc0000135). Click on OK to terminate the application."

I downloaded everything to a folder on my desktop and extracted/installed the files as instructed. I deleted and downloaded/installed iFaith again and get the same error message.

I’m running (oh, I’d forgotten how incredibly annoying it is) WinXP SP3 in a VirtualBox VM on (my preferred OS) Ubuntu 11.04. Have had no problems installing or running other applications – eg, I downloaded and installed the latest iTunes tonight.

Any ideas?

It workssss for me :slight_smile:

but : for shsh, unable to stay in dfu mode, always return in restore mode after 30sec in ifaith :confused: (xp pro last itunes 10.6)

so i tried on an old pc (xp home, itunes 10.2.11)

shsh : ok now!

but wenn i try to restore (the final patched firmware) always error 1602, 1600 in itunes (10.2.11 & latest 10.6)

but finaly, install an old itunes on another pc (windows xp pro, itunes 10.5.2) and it works :stuck_out_tongue:

thanks for your help, good luck :wink:

Hy!

you have first to install .Net framework 3 (not 4) :wink:

 

I must try that, I always get error 1600 at the end. Did you have the powercord plugged in?

I believe that all the rest is good for you (?), so try like me on a different pc (also tested itunes on mac, but don’t work)

found this : http://www.oldapps.com/itunes.php?old_itunes=7014

i was using also ireb, to turn atv in dfu mode; and wenn its good, open itunes and restore your patched firmware.

I tried with and without cordpower, you have to power led blinking, if dont work, put powercord and retry!

Maybe stupid question, does it matter if i`m logged in with my itunes user account or not?

Maybe a dumb question, but just 3, or do I need 1 and 2 also? 

Thanks for you help. Much appreciated!

you need just the “3”, because 4 seem’s not working for me.

you can found it on microsoft page (google search --> net framework 3)

 

No, you don’t have to be logged in Itunes :wink:

Does this work on 4.2.2??

Thanks to both cybernuke, ormanton and jailbreakappletv.com to post this. in two links. However cybernukes link to the seasonpass didnt work on Mar 13 and 14th 2012. 

LINKS – http://forum.firecore.com/topic/7292 AND http://forum.firecore.com/topic/7279

I was able to successfully JB apple tv 4.4.4 using the steps created by jailbreakappletv.com. did this on windows Vista Ultimate OS and itines 10.5.3.3. A very special thanks to the guys created the above tutorials. 

Here are some of my comments >>  

  • There is a typo in the seasonpass version mentioned in this tutorial. The one I downloaded was Seas0nPass_444 – 0.3.52.4509 instead of 4905 thats mentioned in the tutorial. 

  • When asking to connect the ATV, only connect the USB cable, Leave the power cable unplugged all the time. Thats what i did to JB my ATV. 

  • At the end of part 1, you will have created an ssh file named 000000XXXXXXXXXX_Apple_TV_2-4.4.4_(9A406a)-blobs.ifaith — The XXXXXXXX are some unique number for ur ATV, dont ask me, i aint have a clue about that ;) 

  • In Part 3, Seas0npass downloaded the official AppleTV2,1_4.4.4_9A406a_Restore.ipsw in C:\Users\Documents\Seas0nPass\Downloads and also create a custom SP firmware in C:\Users\Documents\Seas0nPass\ which will be of the filename - AppleTV2,1_4.4.4_9A406a_SP_Restore.ipsw. 

  • In Part 4, Step 1 - i dont recall creating a folder in the beginning as mentioned in the step. However, you can create a new folder called “Finish” in this step.

  • In Part 4, Step 2, The file name to be dragged to Total commander is AppleTV2,1_4.4.4_9A406a_SP_Restore.ipsw. The left side of the Totalcmd will display the files from the AppleTV2,1_4.4.4_9A406a_SP_Restore.ipsw… The dmg files that i found were named 038-3845-002 AND 038-3848-002 

  • In Part 4, Step 6, the word “Firmware archive” confused me for a moment. The key is to overwrite the dmg files on the left of the window with the ones that were dragged over in the earlier few steps. 

IT IS WORKING!!!YES!NO ERROR 1600

this is the way to go guys:

I wonder, could I use this method together with my AppleTV2,1_4.3_8F455_SP_Restore.ipsw file

to inject an old firmware on my jailbreaked 4.4.4?

 

 

Don’t I get credit for correcting the error in Part 4, Step 4 and 6 as I pointed it out?

I still can’t get away from Error 9 and it seems I’m getting no help either.  It’s frustrating.

Were you able to jailbreak the 4.3 firmware?  I was able to jailbreak 4.4.4 using this method but I’m having problems with 4.3. Here are the questions that I have.

  1. At Part 2 Step 3: Choose "Browse for the iOS 4.4.4 (9A406a) IPSW" and open the Apple TV Firmware file that was saved initially." I can't find the ipsw resotore file for 4.3 (2557).. Do I need it? or should I build the IPSW using the IFaith software?  I think there's an option.
  2. Part 3 will create the ipsw for version 4.4.4.   Do I need to find a version of SeasOnPass that will build a 4.3 IPSW?  
thanks,