Jailbreaking 5.1.1 (5433)

Hi All,

I have a Apple TV 2gen I’m trying to jailbreak. I downloaded seasonpass and follow the instruction everything went well until it comes to the part where it open the firmware box to load the the firmware on the ATV. The box will open and nothing will happened it will just sits there, I would also get a error on season pass " fail to load firmware"

Can someone please help.

Thanks in advance.

 

 

Got the same problem - did you already get an answer?

This was due to a change in the iTunes 11 side. If you download the latest seas0npass it should work properly.

If we are talking about ATV firmware 5.1 then it is not yet jailbroken.  The latest jailbroken version is 5.0.2.  To make matters worse for you it does not appear to be possible to downgrade from 5.1 to 5.0.2 and end up with a jailbroken ATV2 (not sure about the ATV1 but I have tried multiple different downgrade proceedures from 5.1 and none have worked).  Best thing to do is to go ahead and restore from your PC/Mac to the latest firmware 5.1 and then wait for a jailbreak.

am I reading you correctly when you’re telling him that you can’t downgrade atv 2 5.1 to 5.0.2? Have you read the thread next to this one that says “Breaking News: Apple is signing 5.0.2 (again)”? Essentially until apple no longer signs atv 2 5.0.2 firmware any apple tv 2 can be untethered jailbroken because any apple tv 2 can be downgraded to 5.0.2 at the moment. Yes it can’t be jailbroken and still be on 5.1 you have to downgrade to jailbreak at the moment.

Yes, Apple is signing 5.0.2 so you can definitely install that firmware version. However, my experience has been that, after upgrading to 5.1, it is not possible to jailbreak 5.0.2. I downgraded to a non-jail broken version of 5.0.2 and then used Seasonpass to attempt to jailbreak. Seasonpass will appear to work (even showing the Firecore logo instead of the settings icon in the ATV2). However, none of the jailbreak features are available. Maybe I am the only one experiencing this?

I have two ATV2. One has AFlash backups to 4.3.3 which is what’s its running now bathe other one I don’t use because it can only be restored to 5.0.2 which is unstable at best so I’m interested in upgrading the 502 to 5.1. Can anyone verify what’s has been said here that after upgrading even if you step back down using seaonpass you can install AFlash?

Also I have noticed after using seaonpass it does show the firecore icon but after unplugging and connecting to the TV the JB is gone but if I reboot it again it comes back. I have seen this more the. A few times. Could this be the problem seen with the 5.1 down to 5.0.2 not working?

Don’t know that all makes since or not.

Thanks.

Actually I have successfully downgraded 5.1 to 5.0.2 and jailbreak it at the same time. There actually wasn’t anything different than jailbreaking from a lower firmware. When you say none of the jailbreak feature what do you mean? did you try to install atv flash? I was able to install all the standard stuff like nito tv and xbmc.

if you are asking if you can still install atv flash after downgrading and jailbreaking from 5.1 yes I have done this. as for the firecore icon not showing sometimes this actually happens to me too but rebooting by holding the down direction and menu at the same time on the remote usually gets it back. I usual get this if I unplug the apple tv and leave it unplugged for awhile but a warm reboot always works for me.

Thanks Dknlght

Yes this is a very confusing thread. If you were to believe it, you would think you could not jailbreak if you are at 5.1.1. I have two ATV2’s and both showed a DISPLAYED software version of 5.1.1. I was easily able to jailbreak both of them with the current Seas0npass. The displayed software version now shows as 5.0.2. Its untethered and been working fine for over a week on both ATV’s. 

That’s my fault.  I was mistaken when I said you can’t roll back to 5.0.2 from 5.1. I have now successfully done it. As far as I know you still cannot jailbreak 5.1.

 

how do i roll back im on 5.1.1 want to go back to 5.02

My ATV2 showed a displayed firmware of 5.1.1. I simply downloaded the most current Seas0npass and ran it. When it gets to the iTunes part and loads firmware let it run a while. Mine never said completed in iTunes, but a message popped up from Seas0npass saying it was successful. I have two ATV’s and one went without a hitch, but the second failed on the first try and then worked on the second. If you have issues I would suggest doing a normal restore in iTunes before you run Seas0npass. I did not manually roll back my firmware. Mine both showed 5.1.1 and I just ran Seas0son Pass and when it was done the displayed firmware changed to 5.0.2.

I want to jailbreak my apple TV with seas0npass, now I have the iOS 5.0.2, but I want to jailbreak it with iOS 5.1.1, can someone help me, because I downloaded it the last version of seas0npass and the Boot Tethered option is always turned off.

 

Thanks for your help, regards

There is no jailbreak currently available for 5.1.1. The latest version which has a jailbreak is 5.0.2, and this is an untethered jailbreak.

Still not sure why people say you cannot jailbreak 5.1.1. Both my ATV’s showed a DISPLAYED firmware version of 5.1.1 and both were easily jailbroken with the current SeasOnpass, untethered. 

Boot tethered option ONLY shows if you need to Boot Tethered AFTER you have already jailbroken the device. Do a fresh restore in iTunes and then use Seas0npass to jailbreak it. You do NOT click on Boot Tethered to do the jailbreak. That is only to re-boot up the ATV if you unplugged it or needed to reboot for some reason and it had a TETHERED jailbreak on it. Once you do the jailbreak just hook it up to your TV and turn it on. You shouldnt need to boot tethered.

 

WRONG. 5.1.1 is the firmware. 5.0.2 is the iOS version. They are one in the same. I have noticed, depending on the manufacturing date, that some apple tvs show iOS or firmware version in the settings. 

if you have an apple tv displaying 5.1.1, jailbreak with iOS 5.0.2.

Hi , 

 

i bought ATV 3 , the version is 5.1.1(5433) i tried to downgrade to 5.0.2 but can not , the Error msg 

as show in Attached, 

 

i think  , it can not be back to older version ?

appreciate