Jailbreaking 4.2.1

Hi all, I purchased a Apple TV 2 device and realised it was running 4.2.1 software which I am hoping I can jailbreak untethered after reading a sticky by the admin stating that there is a untethered jailbreak for the software i have on my Apple Tv 2.


Is it possible ?  If so, is there a link to a tutorial here on FireCore outlining the method to carry out this procedure…?


Any help would be greatly appreciated.



Possible to save blobs even if device isnt currently jailbroken?

I have five on 4.2.1.  I spent weeks and weeks.  Even sent them away to some expert.  He couldn’t jailbreak them either.

Give up and put them on 5.3 while you still can.

i just successfully jailbroke mine. i stiched the .dmg files from snowbreeze image to ifaith signed image and it works great

I tried with 4.4.4 snowbreez but failed to restore the firmware


How can this be done…?

Getting an error saying that this apple tv 2 is not eligible for this version.

Happens to every ios i select via seasonpass…

I guess I was just very lucky with the two I jailbroke, including one 4.2.1 last night.

You indicated that you tried every version of SP so my solution does not apply, but FIRECORE and SEASONPASS are simply not “synchronized” when it comes to this version, something which can understanably defeat perplexed users.

Version 4.2.1 in staff member James’ version “Bible” corresponds with 8F202.      

However, version 4.2.1 in Seasonpass corresponds with version 8C154 – Not 8F202.  By choosing 4.2.1 (8C154) from Seasonpass, you WILL receive the dreaded “Not eligible for this version” message.

In Seasonpass, you actually have to choose the 4.3 (8F202) option if you are to have any chance of this working – which obviously doesn’t happen in all cases.  But it certainly did for me.

James’ Version 4.2.1 (8F202) corresponds to what you see in the ATV settings menu.  Why the Seasonpass options differ and are confusing really makes little sense.

I’ve been able to jailbrake both my 4.2.1’s by choosing version 4.3 (8F202) in Seasonpass.  When jailbroken, they read 4.2.1 in the “Settings” menu.

Is version 4.2.1 another one to avoid based on others’ problems?  This is becoming a mine field.


Thanks for the input Max :slight_smile:

So it appeared my device was stuck in recovery mode which i used tinyumbrella to exit and selected 4.3 via seasonpass like you advised and worked successfully.


Device running 4.2.1 UNTETHERED :slight_smile:


Dont know why many people are saying it cannot be done. Faith people, FAITH !


Hi nuggy. How about 4.4.4 ver that fail yo download the firmware signature
I did jailbreak more than 10. But this time 2 days ago have this problem

I think it just comes down to you and your luck as i have read many success stories and just as much failed…