Jailbreaking 101 w/ Seas0nPass (Mac + PC)

If anyone is having trouble entering DFU mode, I have good news.

 

After much fiddling, I discovered a way to get into DFU mode 100% of the time. It's the Power Supply that is key here.

 

1. Disconnect everything from ATV.

2. Plug in USB to ATV & other end to your Computer & wait until for the consistent flash (4 or 5 seconds usually).

3. Hold MENU & PLAY/PAUSE for 7 seconds. DFU MODE ENTERED!!!

4. Plug in Power Supply to ATV.

 

Done!

Let me know how you go.

I finally found a solution to my problem.  The Seas0npass instructions mention to keep your aTV unplugged prior to entering it into DFU mode.  However, the power cord has to be recently removed prior to doing the 'Menu/Play' step with your remote.  The jailbreak steps work best when the computer and the TV are close by.  Mine weren't and having to plugging and unplugging the power defintely caused issues.  I ended up bringing my mac by my TV and doing everything from there.  Hope this helps and saves others some time.

I tried multiple times to jailbreak my atv. LOL i never plugged it in and started it up normaly. Just when for the hack. Restored it and started it up. Then re jailbroke it. Booted up fine :D yay :D

I posted my detailed steps for a successful tethered boot here:

http://forum.firecore.com/topic/3683?page=1#comment-14155

It works every time.

Good luck!

Not fixed for me. Using Sea0nPass 0.6.7 and 0.6.8 resulted in ethernet working but WiFi not working. Same is still true for me with 0.6.9 so I'm back to stock firmware. Maybe the WiFi fix and the untether will come out at the same time! :P

Did you do a restore to stock firmware before using Seas0nPass .0.6.9?  That's what it took to bring WiFi back to life for me. I had the same issue, where ethernet worked but wifi did not.

Yes, I did the stock restore before 0.6.9.

Hi and thanks for all the hard work!

I am so close now...

  • Successfully created new IPSW 
  • Successfully jailbroke
  • Manage to put in DFU (almost every time :))
  • Seas0npass detects DFU and transfers two files and says DONE!
  • I connect HDMI and get hanging iTunes logo on TV.

I am on 220V power but that should not matter, right? I had it running successfully without jailbreak.

Should I be on wired LAN? Is it perhaps the fact that I am on wireless LAN that causes the problems?

I have tried every unplug/plugin power/usb trick I have found.

Thankfull for any hints.

RE Jail braking the aTV

I have a w2nd version aTV

 

and the ATV flash  wont find my aTV??

 

steve

 

so what you are saying is ,when finished the jailbreak and the boot tether when prompted to disconnect usb that the power has to stay connected to the atv

is there another way of doing this as my computer and tv are not side by side

or do we have to wait for a untethered update???????

 

Unable to upload IBSS!

 

I have lastest itunes 10.1.2 , Seas0nPass 0.69(036).

I get unable to upload IBSS! error message when tethering my ATV2

Attached SP_Debug.log file.

Thank you very much .

 

Looks like an extension cord is needed.  I am going to need about 25 ft to get from my mac to my tv.  the last step as explained by firecore is to unplug the usb and plug in the hdmi but it says nothing about the power cord.  thanks to earlier post we know the power must stay on. 

after this all done what happens if I have a power outage?

i am after the webbrowser in atv (black) is this really worht it?

 

 

I have been trying to jailbreak me apple tv2 with the tools you mentioned but till now NOTHING!!!!

Would be nice if you could solve this little problem....

I bought ATV Flash Beta and tried to install it. The installation seemed to work ok until I ended up getting this message "Sorry, the installer could not connect to your AppleTV. Help!" Just before  I received that message the installer saw my Apple TV with its ip number.

I am just wondering if jailbreaking with Season Pass worked or not. How do I know it did? I know my Apple TV was visible in an iTunes window after the installation.

What should I do now to successfully install ATV Flash. I am running Mac OS X 10.6.6

Thanks

 

I've followed the direction and I believe I have successfully jailbroken my AppleTV2, even tethered rebooted it. It looks good so far. However, the menu does not show any of the features shown in the promo video. I was looking for the media player menu but it is no where to be found. What is going on? What else do I need to do after jailbreaking and tethered reboot?

1. atv2 works in 720p 50Hz (not 60Hz) mode

2. (xbmc 10.0.7) avi files with ac3 sound (optical, hdmi out) works wrong, hear cracking.

 

I installed with no problem, was connecting my ATV2 to TV, ATV2 would only boot to Apple logo screen then there is no screen whatsoever.  Tried rejailbreaking many times, please help!!!

the same for me, black screen !

The software works.  Apple TV 2 is a bit finicky, so you have to be very meticulous about the timing of the cord swapping.  I tried a dozen times with no success until I watched this kid's video on youtube.  I gotta give him props.  I was doing everything correctly, but it didn't work until followed Ty's instructions. 

http://www.youtube.com/user/tysiphonehelp?blend=1&ob=4#p/u/13/vFqHCZssCGg

If you are afraid of the link try this:

After loading/restoring the ipsw file, unplug everything, shut down seasonpass.  Plug the mini usb and power into the apple tv, but not into the mac or powerstrip.  Start seasonpass, let it do it's thing for a sec until it's prompting you to do the dfu mode stuff, plug in the mini usb, give it 2 secs and when the apple tv starts blinking quickly, plug in the power, quickly. Then hold down the menu and play/pause buttons.  As soon as the pop-up says it's safe to unplug the mini-usb, get on the good foot and plug in the hdmi.  

None of this worked until I moved my imac into the living room.  That's how quick you have to be about the cord shuffle, quick.  

This is on a 2007 imac, an apple tv 2 I bought from best buy on 3-27-11 with ios 4.2.1.  I used the latest version of season pass found here:

http://support.firecore.com/entries/387605

and finally found out I jailbroke it when aTV Flash (black) Beta4 actually worked.  Now xbmc, plexo, and loads of other stuff I don't know how to use are loaded on my apple tv 2.  Props gentz

 

 

 

Thanks Deanius, 

I appreciate you highlighting the key to making this work. I also found and reviewed Ty's video *(good stuff for everyone to review http://www.youtube.com/user/tysiphonehelp?blend=1&ob=4#p/u/13/vFqHCZssCGg).

The thing that WORKED FOR ME (after) doing the initial creation & restore with the new IPSW was...

 

After putting the ATV2 into DFU mode and your ready for the tethered boot to start. Go ahead and plug the power cord in fully. Now once the tethered boot is successful immediately unplug the usb and plug in the HDMI cable. Since the power plug is already in you shouldn't have any issue plugging in the HDMI in time.