Jailbreaking 101 w/ Seas0nPass (Mac + PC)

Full details on jailbreaking the Apple TV 2 with Seas0nPass can be found here.

Trouble with DFU mode

Pre-launch checklist

  1. Ensure you're using a silver (aluminum) Apple TV remote. The older white (plastic) Apple TV remotes are missing the dedicated play/pause button and will not work.
  2. Disable the 'remote control infrared receiver' option through System Preferences --> Security --> General. (Mac only)

If you're having trouble getting the Apple TV into DFU mode try the steps below once you're at the 'Waiting for DFU' step.

  1. Disconnect Apple TV from USB. 
  2. Reconnect, and wait for the rapid flashing light.
  3. (Optional) If you're not seeing a rapid flashing light, hold down the menu and down arrow buttons for about 7 seconds (or until you see the rapid flashing light). 
  4. Hold the menu and play/pause buttons together for 7 seconds (count slowly - one thousand 1, one thousand 2, one thousand 3, etc...)

If all else fails...

  1. Connect the power cable along with the USB cable to get into DFU mode. Disconnect the power cable once the restore process begins.
  2. Try a different USB cable - a good, low cost cable can be found here.

Mac specific issues

  • Some users have reported issues when Filevault or Clean My Mac are in use. Disabling these should resolve most issues that arise during the jailbreak process.
  • If you're getting errors when creating the IPSW (stuck on Patching Ramdisk) please try the fix found here.

PC specific issues

  • If you're receiving errors regarding Microsoft .NET framework you can download and install the latest version here.


I did everything correctly and when I connect my apple tv (black) to the HDMI it is stuck at the Apple logo as the light on the device is just a slow steady blinking...any idea with what going on?  I have jailbroken and did the tethering as well...thanks!

This was what I observed when I booted the aTV untethered... try repeating the tethered boot.

I did to a tethered boot. I am a bit confused here. Is the process as follow?


- jailbreak using SeasonPass with the atv attached to a Mac only with the usb wire.

- unattach temporariliry

- reattach usb and put in power chord at which point it boots ( do you have to force a boot somehow or is pressing tethered booth enough)

- unattach the usb cable

- attach to TV and ethernet

Install atv flash from Mac ( it sees the atv). 

Go to ATV


At this point my atv is showing the white Apple screen forever



Now what?


Each time we restart the atv will we then have to jailbreak again and go through the whole process or is the jailbreak permanent until a firmware upgrade?


Do we have to keep the atv attached to the mac via the usb cable?


I have tried all of this several times. The jailbreak part is easy ( with .66 of SeasonPass). It would be nice to be able to reuse the modified restore images.


I think I will wait.... don't want to brick the atv. Plex is nice but not that nice.




Dear Philip,


I experience exactly the same problems. It works one go, and than next time you start it up (next morning the 2nd time) it got hung and a restart lets the apple TV hang on the Apple Logo. I restored the Apple TV 2 now with Apples update. I hope it is not bricked now.

I will wait further developments, it is now to buggy on several levels unfortunately.

Warmest regards,


The same for me here, it works till I toggle the power (to restart) and the there was the apple logo..... for ever....

Hopefully you can fix that

I have the exact same problem as described above. I hope there's a solution.

I've been unable to get my Atv 2 into DFU mode.  Tried the instructions and other tricks online but still won't work.  Any suggestions?  I'm on 4.1.1.

make sure you are putting your apple tv into dfu mode before you do the tethered boot



I can help you out if you can tell me exactly what you are doing and at which point of the jailbreak you are doing it. I have been raping my apple tv 2g the past couple of days working on figuring out other peoples problems :)


happy to help,

kerryk.17854 (nandor690)

Hi James,

I think for some ATV users the jailbreak process goes fine, but tethered boot will not work with the current instructions to put the ATV back into DFU mode. The power cable has to be not connected to get it into that mode. If the SeasonPass instructions could be modified to include that then that would be great. I tried many times with SeasonPass and the tethered boot. It failed right at the DFU stage.

I could be wrong but I suspect that is the problem. The utility is otherwise really nice for me.




I had everything up and running for a couple of days.  While playing with Plex, I caused my ATV2 to reboot.  At this point I had to do another tethered boot and all appeared to be okay until I noticed that the ATV2 could no longer detect wireless networks.  I restored firmware in iTunes & that cured the issue.  Please note, it did not just forget networks, it could not detect them at all.  I will re-install atv Flash tomorrow when possible.


Wonder if others have run into this issue?  My cable box rebooted, so it could have initially been related to a power surge rather than atv Flash.



Ok, I think I have this figured out. The reason why seasonpass fails with me is that my ATV will not go into  DFU mode with the usb and power cable plugged in. I then used PwnageTool and this link



which describes how to jailbreak it. The jailbreak went fine but the tethered boot didn't because the explanation that he gives to get the ATV back into tethered mode didn't work in my case. I had to


- connect usb (wait 10 secs or so) and then the power

- press menu+down for 6 secs ( until you get the faster flashing)

- remove the power <-- this is the key

- put the ATV into DFU mode by menu+play for 7 secs or so ( until faster flashing)

- plug in power

- it tranfers what it needs to

- you get this weird error at the end but disregard

- disconnect usb and plug in HDMI and then my network cable

I can now ssh in.


There is no way SeasonPass will work on my setup without slightly modifying the instructions to get it back to DFU mode when tether booting, but apart from that minor modification I am sure Seasonpass would work and that would be far nicer.


I am now ssh'd into the ATV and I can install atvflash, although I'd like the latest version of Plex.




Edit: Just installed Plex. Will remove it and install atvflash when it supports the latest Plex client.

Hi all, i would agree that the firmware flash seems to work find,  I am unable to tether boot the unit, half a day :-) it seems timing is important, although (laughing) i cant be fast enough.

Looking forward to getting this working sometime, although i searched for the logs and cant find them, I use filevauilt and although trying several install locations wonder if this is one reason it is not working, oh well it is a beta and i will keep looking back for tips.

Hi all, i would agree that the firmware flash seems to work find,  I am unable to tether boot the unit, half a day :-) it seems timing is important, although (laughing) i cant be fast enough.

Looking forward to getting this working sometime, although i searched for the logs and cant find them, I use filevauilt and although trying several install locations wonder if this is one reason it is not working, oh well it is a beta and i will keep looking back for tips.

Thanks Kerry.

I downloaded Seas0nPass and followed the instructions on http://support.firecore.com/entries/387605.  I'm having no problems up to step 4. I am following the instructions to plug in the aTV with my micro USB (and not the power cord).  I've tried just pressing Menu/Play for 7 seconds but nothing happens.  Other instructions recommend Menu/Down Arrow for 6 seconds (or until light flashes) and Menu/Play for 7 seconds (or until light flashes).  My aTV is recognized by iTunes but just sits there.  The screen on Step 4 doesn't go away.  Keeps telling me 'Waiting for device to enter DFU Mode'.  That's pretty much as far as I can go.

Awesome engineering job, even script in itunes knocked me over as it paused and I was about to select IPSW ...lol


Obvious bug on mine here are the steps I took:


First Time:

Tether boot worked first time youtube also ran although did not

have Home Sharing On and Firecore ATV Black software could not see

Ethernet number of ATV but only a AirPort Express

Could not seem to get Home Sharing On to connect


on 2 restart no menus in Movies or Internet - Brocken

on 3 restart no video not even if you did not do tether boot

on 4 restart no video

rebuilt IPSW and restored

on 3 restart no video

on 4 restart no video


not sure but looks black listed now, problem with this approach is u have to

log into home sharing to get music and thats where I do't trust Apple 

not to be looking over my shoulder.


ooops will try itunes restore back..... keep me posted

Entering DFU mode for jailbreaking was not a problem. After that i had to find the right time to plug the power supply for doing a tethered boot.

Except this: smooth sailing.


The Webbrowser kind of sucks (Ad popups will replace your desired url, some javascript url onload foo does not work) and i do not need the weather app but Plex looks very promising. I love it.


Thank you so much!

Hey James,

I did everything according to firecore and you after a power cut then the wifi disapaired. Before i could update to aTV Flash but with the new version of SeasOnPass I just get the standard apple software without aTV Flash. Could It have something to do with Itune used to update the software? Does Itune put back the original software in some way? or do you have eny oterh ideas? (I choose the right file to be used to update the software after pressing Restore and holding the Option-key) Everything looks correct while updating.


Best rgds,


Hi! I want to jailbreak my ATV 2nd gen. I downloaded the seasonpass software and press create ipsw. As the download is complete it goes to unzipping sofware. After that it goes to patching ramdisk. This step never ends in my case. I let it run over the hole night and it was still patching ramdisk next morning.

What can I do?