Jailbreak

Hello!!! I’m new in this forum. I tried to jailbreak, but I got this problem:

SeassOnPass os unable yo establish a connection Whith the Cydia iFaith servers. Please check your internet connection and firewall settings.

Is it possible to do the Jailbreak in2018??
Thanks!!!

Hey I got the same problem here. Maybe someone can help with this

I also have the same problem… This is just pure chaos :slight_smile:

Me too. All firewalls of, no connection to servers?:exclamation:

Hey guys,

Yes it is possible to jailbreak your Apple tv 2 in 2018, I just did it, see below:
After a few tries to install it and after trying to recompile from the GitHub sources and try to get that working I tried the following and I was successful, hopefully this will help somebody else in the forums, it helped me:

-Download Telerik’s JustDecompile (https://www.telerik.com/products/decompiler.aspx)
-Create a copy of seas0npass.exe and name it “seas0nPass2.exe”
-Open that copy of the file with JustDecompile
-Click on the plugins button in the toolbar at the top
-In the bottom part of the screen click the install button for assembly editor and close the window
-Expand the tree on JustDecompile under “Seas0nPass2.exe”>Seas0nPass.exe>Seas0nPass.Utils.Blobs>BlobInfoHelper>GetBlobsInfoFromIFaith
-Click the plugins button>then click Reflexil
-In the new window shown at the bottom of your screen select all lines in the instructions grid, right click it and select Replace all with code
-Type the following code inside the new window
Seas0nPass.Interfaces.BlobInfo blobInfoArray = new Seas0nPass.Interfaces.BlobInfo[0];
return blobInfoArray;
this so that your contents look like this:
static Seas0nPass.Interfaces.BlobInfo GetBlobsInfoFromIFaith(long ecid, System.Threading.CancellationToken cancelToken)
{
Seas0nPass.Interfaces.BlobInfo blobInfoArray = new Seas0nPass.Interfaces.BlobInfo[0];
return blobInfoArray;
}
-Click compile, then click ok
-in the JustDecompile tree under “Seas0nPass2.exe”>Seas0nPass.exe, right click it and select Reflexil v2.1>Save and reload
-Close JustDecompile
-Launch Seas0nPass2.exe, proceed with the standard instructions

@firecore employees, can you please make this program work without us having to do this wonky stuff?

Thanks

1 Like

This didn’t work, it wont let me recompile. its telling me that there are paths missing. looks like visual basic paths.

Is JustDecompile totally free?
Because of the registration!

Thank you at “killer89“?:exclamation:
This worked very fine for me on Windows 8.1!
After I recognized if there is a “0“ and not an “O“ in Seas0nPass, it run 100% and my ATV2 is now successfully patched!
Great work, killer89??

I don’t see “Seas0nPass2.exe”>Seas0nPass.exe>Seas0nPass.Utils.Blobs>BlobInfoHelper>GetBlobsInfoFromIFaith
expande but is not there.

What exactly is missing?
The path?
Or the content in the path?

The path.

Cheers

Did you drag & drop the Seas0nPass2.exe in the left side of the JustDecompile window? And did you download the additional plugin Assembly-editor?
I don´t know if it´s necessary to see the path, maybe.
In Front of “Seas0nPass2.exe” there is a small Triangle. Klick it for opening the tree-structure. Now klick through the tree till you reach the searched path.

Thanks,is working now…found the path…

worked like charm!
I had some issues with using JustDecompile (did not start on Win10), so I used dnSpy instead.

Thank you!

Where exactly am i typing this into? Under Fields stubs?

In referenced assemblies - look for the context he posted. It took me a minute to figure out as well.

this worked to get me past the server error issue but now i get a critical error at downloading signature. I was trying to jailbreak to the most current version on the list, 6.2.1 at the bottom, goes through download, decrypt, etc but gets critical error when downloading firmware signature, looked in log file exception at :“got invalid response from TSS server” , I have not tried the 5.3 default jailbreak, but would like the most current, even if tethered, Any ideas?

Can somebody upload the modified files? The instructions aren’t really clear.
Thank you

Ok, it worked with 5.3. Just follow the instructions carefully. Ridiculous that this is necessary, however I am using a W10 computer. I think the apple files work as is.

You’ve got to be kidding! Customer support? Has firecore EVER answered a support request???