jailbreak problems atv2 5.0.2 (4250)

hi this is my first post so bear with me ! had jailbroken atv2 before on 4.4.4 no probs . i have updated itunes to new version 10.6.3 followed all intructions to the letter the only problem was i have to use the power cord to get it in to dfu mode. once power lead is used season pass finds atv and carrys on till i get the "restoring in itunes … please wait while script is running…  itunes opens up but i get no extracting software message in the top itunes window . left for an hout and its still "please wait while script is running " message like i said the first jb on 4.4.4 first time but the new version tried about 4 times to no avail ! im running windows 7 thanks for any help in advance ! oh i more thing ive tried reinstalling itunes and that didnt help ! 

Download iREB from http://ih8sn0w.com and put your Apple TV 2 into PwnDFU mode. (You may need the power cable to get into DFU mode; once in disconnect the power cable and use iREB to enter PwnDFU).

Once in PwnDFU mode open iTunes and hold shift and click the Restore button for the Apple TV. Go to your Documents\Seas0nPass and look for an IPSW with the letters SP in it. Select it and you should start restoring.

thanks matty will try that when i finish work later and post results ! 

Hi Matty, my situation is similar to Dolmioboy (I’ve jailbroken 4.4.4 before, I have 10.6.3 iTunes and atv2 5.0.2 (4250)).  I followed your instructions but got the error “The Apple TV “Apple TV” could not be restored because the firmware file is not compatible.”  Incidentally, when the USB is connected and I unplug the power from the atv2 it turns off (windows doesn’t see it and the light goes off), my other 4.4.4 atv does not have this problem.  I’ve tried numerous USB leads.

Hi guys, I think I’ve found my problem.  My device is an atv3.  The device looks identicle to the atv2 but the model number (settings/general/about) shows it to be MD199X/A which Google tels me is atv3.

If it is a 1080p compatible model then it is an ATV3.

big thanks to matty!!! followed the instructions and worked a treat!!! thanks again 

Hi! I’ve been running aTV Flash on ATV2 4.4.4, I think, and today I was updating and decided to install RemoteHD. During installation the TV screen went black and nothing happened. Finally I had to remove the power cord and try to reboot. Impossible. I hooked up to iTunes and restored to fabric settings. After restoring and updating I was running 5.0.2 (4250). Then I ran Seas0nPass and everything seemed to run smoothly. I got the message “Done” or similar. When I connected to the TV-set again it turned out not to be jailbroken. The FireCore logo was attached to the settings button, but when I pressed it the original settings menu showed up. How do I solve this issue, anyone?

That is expected behaviour if your jailbreak has been successful!

It sounds as if you have not carried on to the next step of installing ATV Flash?

I’am a little embarassed to admit that I forgot to install aTVFlash but this is what happened.

I tried to install aTVFlash but got this message “Oops, it looks like your Apple TV has not yet been jailbroken.”

It seems like when Seas0nPass finished that iTunes continues to restore to fabric settings. 

But this time I didn’t see the FireCore logo. Should I try yet another time with Seas0nPass?

I usually don’t rush into things because I realize this is what happens. I forgot to install aTVFlash when the jailbreak was completed. I must have remembered it as a single process so when I didn’t recognize the interface I ran Seas0nPass once again. And the second time the logo didn’t appear on the settings button. Now I’ve tried several times to jailbreak and Seas0nPass says everything runs as it is supposed. After this message iTunes continues to restore to fabric settings. And when connected to the TV there is no logo on the settings button. Any ideas?

Problem solved. I went on to a third computer and this did the trick. Finally I could install aTVFlash. Why it worked i don’t know, so if anyone can explain it feel free to do so.