Jailbreak leads to rapid flashing on ATV2

I have been trying to jailbreak my ATV2 (with the latest updates :frowning: because I didn’t know NOT to do that) and have been repeatedly unsuccessful. It seems to “work” at first - seas0npass installs, everything looks hunky-dory, I plug it back into hdmi, looks good and get the temp FC logo… then I go away and have snack, come back and my ATV is blinking like crazy and the connect-to-itunes logo is on the screen. When I connect to itunes, my only option is to reformat it and lose the jailbreak.

 

I’ve done this several times, in different ways suggested in different forums, and now it doesn’t even get to the beginning stages of “looking good” before the rapid flashing starts. I’m not really sure what I’m doing wrong/what to do. I’m not a tech-genius girl, to be sure, but I consider myself tech-competent- this experience though, is making me feel like an idiot.

 

Any suggestions??

You do not mention doing the tethered boot as described in http://support.firecore.com/entries/387605-jailbreaking-101-seas0npass. The connect to iTunes normally means that the ATV2 is waiting for the tethered boot via SeaonPass (NOT iTunes). You need to do the tethered boot any time the ATV2 loses power or does a hard reset.

Thanks itimpi - I have tried to do the tethered boot as well, and it is the same issue where the moment I unplug from the computer I get the dfu-style flashing and it won’t let me do anything but reboot with itunes.

 

I will try it again, to make sure I didn’t royally screw it up somehow, but I think it still fails, even when tethered.

Are you making sure the power is connected when doing the tethered boot and is left connected when you remove the USB and plug in the HDMI to connect to the TV?

Are you making sure the power is connected when doing the tethered boot and is left connected when you remove the USB and plug in the HDMI to connect to the TV?

 

I am a complete idiot and was not unplugging the usb and reconnecting the hdmi fast enough… wow, I feel dumb!

 

Thank you for the help - works great now!