Jailbreak is not working

Hi, I used the newest version of Seas0npass to jailbreak my Apple TV 2 but its just not working.
Here is what happens:

System: Apple TV 2 with Software 6.2.1
downloaded 5.3 and successfully installed the same, its working on the TV
MAC OSX 10.10.5
iTunes (iTunes however doesnt seem to do anything then flipping when trying to jailbreak)

downloading Seas0nPass and unzipp into my downloads folder
open Seas0npass with admin password
click Create IPSW
here is already the first deviation from all the Tutorials, it wants me to connect my Apple TV via USB
it downloads the software and goes through a process
I am asked to connect my Apple TV via USB and put it into DFU mode
Thats is not really working either, I can get it into DFU mode by plugging in the power, but it seems that Seas0npass is crashing because it doesnt recognize the DFU mode. After I closed Seas0nPass and reopen, it continues the process without further questions
I get a notification that all has worked out just fine
Hooking it back up to the TV: it wants me to connect to iTunes… nothing else is happening

This is like the 4th time I tried it, always with the same result… What can I do do make it work?


Hello Chris,

have you had any luck resolving this issue? i´m having the same problem.

v/r Gunnar

Learn how to use DFU properly if you don’t already:

do not skip step 6! By skipping it you are not finishing the JB!