Jailbreak fail (ATV 2 gen)

I recently tried to jailbreak my ATV 2 gen. The process works fine and i end up with a message saying that the update was done succesfully. When i connect the ATV to the TV it flashes slowly and shows me the apple logo for a short while. Black screen after that. Whe i try to install atV Flash it tells me that the ATV is not jailbroken??? I have no ide where the process failed since it tells me that everything fine. Now i dont know what to do???

Please help


it’s a teathered jail break so now you have to open season pass again and connect the usb cable and click on teather boot. once the process is completed you have to plug in the power cable before taking out the usb calble.

No luck! Same result…

Did you make sure you did not remove the power after doing the tethered boot? Any interruption to power puts the ATV back into needing a tethered boot. You need to remove the USB cable and plug in the HDMI cable reasonably quickly after completing the tethered boot.

I must be dumb… I did what u told me and now it works…


Thank u very much…

That being said… Does that mean that you have to re-do it all again after power cut??? Just restartes it after flash and now it just flashes at me and gives me black screen???

Yes…you have to do it everytime it has been unplugged or lose power.

do you know if that is going to be fixed in an update later? that is very inapropriate to say the least…Grrrrr



I don’t know about inappropriate, but it is inconvenient. An update has not been announced so who knows when.

itimpi suggests the use of a small UPS in the following linked post.  It’s not an ideal solution but if you’re experiencing constant power outages it may be something to consider.  There’s a good reason why ATV2s running untethered jailbreaks sell for considerably more than their tethered counterparts.