Jailbreak ATV2 FW 5.2 Unknown error -1

Hello everyone, 


I search through the forum for an answer for this issue but didn’t find anything.


I have a 5.2 atv2 i received yesterday, it came with stock 5.2 without jailbreak.

So i used the iFaith 1.5.5 do dump the shsh blobs, created a signed IPSW, jailbreak oficial fw with seasonpass, extracted the two imgs from the jailbroken ipsw and overwrited in the signed firmware with total comander, just like the tutorials i’ve always used for jailbreaking own firmware.


But now i Face the unknown problem (-1) when restoring in iTunes.

If i try to flash the signed ipsw it works perfecly, i don’t know what is going on with this thing.


bad time to buy a new apple  tv 2 :frowning:


I have another one coming, I hope it comes with older firmware or already jailbroken.

Problem Solved!!!


Seasonpass was not working using the img swap tricky method, so i Tried snowbreeze 2.9.13 using the shsh blobs option and it worked perfecly!!!


Thank god i had them saved!

what do you mean by that can you give it little more clear instruction. snowbrezz to create custom jailbreak firmware for restore firmware… thank you

Snowbreeze is another tool to jailbreak iOS devices, 

you can get it here.



Assuming you have made a backup of your SHSHblobs

  1. Download the original Apple TV 5.2 Firmware.

  2. Download Snowbreeze,

  3. Open Snowbreeze, select iFaith mode, and select the firmware you dlded

  4. it will create a jailbroken and signed fw on your desktop.

  5. Enter in DFU using snowbreeze instructions and restore the firmware with iTunes.

@edemir. I have been going through the same problems as you mentioned. I did the swap and was recieving the -1 error as well. Now im using snowbreeze, quick question, what can i do if i dont have the shsh saved for the apple tv 2.


I used ifaith to dumb the shsh blob because i dont have 5.2 shsh saved, i recently purchased this apple tv and itunes no longer signs 5.2. I used the dumped 5.2 shsh from ifaith when using snowbreeze to jailbreak, but i get 1604 or 1600 errors. I used two different apple tv 2s, when i plug both to the tv, one has a blank screen, the other has the picture telling me to plug it into itunes. I’ve wasted more than 3 full days trying to fix this and i dont know what else to do. I used ireb’s pwned dfu mode and then used itunes because i read it bypasses all 16XX errors, but i still got the error. Please help. 

My other issue is in ifaith, when i am trying to dumb the shsh blob for my apple tv 2, it constantly gets stuck at upload iBEC, any idea what that is about?


Also is there anyway you or anyone can sent me the SHSH file for 5.2, my email is qumar13@yahoo.com. I would really appreciate it. 


Hi I accidentally upgraded my atv2 to version 5.2 10b144b and couldn’t jailbreak it did a lot of research and thought I was screwed but I finally jb my atv2 using seasonpass right click the create ipsw and select 5.0.2 (9b830) it worked for me, without having any saved blobs or anything :slight_smile:

same problem here … tried to reinstall and jb the 5.2 on my AppleTV … Im sure I’ve saved the 5.2 SHSH (I can see it in TinyUmbrella) but I always got Error (-1) in iTunes.

Downgrade to 5.0.2 worked perfectly instead.

So that means there is a bug in Seas0npass with the 5.2 SHSH implementation? Will it solved in a new version of Seas0npass? 

It seems the developers for jailbreak software on all platforms and devices (iPhones/iPads/iPods/ATV’s) are all aware that cydia screwed up storing iOS6 blobs.

Tried to notify the Firecore team on day one but the info was not looked into.

May explain why people are only managing to restore to iOS5 firmwares, it appears that is the last time any blobs were successfully saved.