Jailbreak & ATV Flash installation - EASY!!!!


If you follow the procedure below, you will easly JB & Install whatever you want.


1) Restore latest iOS from Itunes to your apple TV

2) Download RC6 of GreenPois0n from http://www.greenpois0n.com/

3) Connect your appleTV to USB cabel and power

4) Connect USB to your MacBook or Laptop

5) Start greenpois0n

6) Click Yes on screen with the message If you are jailbreaking an Apple TV

6) Bring AppleTV to DFU mode through

    Press Menu & Down Buttons together until light quickly flashes

    Release both buttons

    Immediately Menu & Play/Pause buttons togerher until light quickly flashes

    Now push Jailbreak button on greenpoison

7) On completion of the jailbreak process, click Complete! button

8) Wait for minimum 40 seconds before disconnecting USB cable until Greenpois0n finishes the jailbreak process on your Apple TV

9) Unplug USB cable, connect the device to your TV, navigate to “greenpois0n”, select “Inject Software” and install Cydia package.

10) After the installation is complete press MENU button to reboot.

11) nitoTV will appear instead of “greenpois0n” heading. You can now install third-party software and plugins, such as XBMC, Exposed, Overflow, BTStack, Weather, etc. (NitoTV->Install Software).

12) Update nitoTV under nitoTV options

13) Install XBMC from nitoTV software installation menus & openshh

14) reboot your appleTV from nitoTV menu

15) Download aTV Flash (black) Beta3 from your account at firecore.com 

16) Run installation of aTV Flash

17) The installation will stop with "*** Installation Failed. Sorry, the installer could not install. Maintenance (Error 8.100)" Don't worry!!!!!

18) Login into yout apple TV with ssh root@XX.XX.XX.XX (IP-Adress of your AppleTV - Password is alpine)

19) run following command there

      apt-get install --reinstall com.firecore.maintenance

20) logout

21) reboot your AppleTV

22) Everything you want is there :-)

23) Install CouchSurfer etc. from maintenance menu :-)


I also connected appleTv to Dreambox via XBMC and whatch TV from AppleTV :-)

Can you shed some light on how you connected your dreambox to XBMC, i would very much appreciate sharing the steps to do so. i am having media lib. on Dream Box and would like to add it as a media source.



@halukm....Thank-you for your very thorough explanation. Unfortunatly i'm not a mac user i'm windows 7 :-(, and for ssh etc i use either Filezilla or Winscp, im not to sure but i think i can run a command line in Winscp, do i put in the command line the full    apt-get install --reinstall com.firecore.maintenance  just as you have typed it?.........Thank-you for any info offered............p.s. or does anyone know if it is done differently in Winscp or Filezilla?

Thanc you you help me :))))))


Not for me, it says package com.firecore.maintenence not found .. :(

interesting.  other comments about this working yet?


Installation worked pretty well, no failure at all. I didn't login with ssh, for now It doesn't look like atv flash, but like nitotv. Says Maintantenance "installed".


Worked for me... thanks a lot, halukm! BTW - for some reason, the aTV Flash (black) installation did not fail for me. I skipped everything after step 16, and my install seems to be working perfectly. I love this little black box (once it's tricked out with aTV Flash (black), XBMC, etc.). :)

It looked good but after installing Apple TV the screen went black and I could not get it back. still working on it. Did I do something wrong... any idea? 

Thanks guys! Finally I got my ATV2 jailbroken!!! YEAH!!!

Nice one! Had the same Error 8.100 as so many others and this sorted it right out! :)

Worked like a charm. Thank you!

did everything on here... no luck.

running osx 10.5.8 and the atv2 is running 4.2.1 (2100)

any help is welcomed.





worked for me!

quick question.... I can get it to work up to clicking the "Complete" button, then wiat for at least before unplugging the USB... my problem is that I just have the blue screen and a slow flashing light on the front when i connect up to the tv.

Should the network cable be connected when doing this?

Even though the jailbrake says it is complete.... the appletv just boots up into it's normal mode.



Hey, I have exactly the same problem.. After "Complete" there´s no signal to the tv (even after waiting 1 min), so I never get to do the "inject software" step.. tried like 5 times, also restoring the apple tv in itunes a couple of times, but still same. Anybody know what's going on?