Jailbreak atv 5.3 - Seas0npass hangs at Restoring in iTunes step

I have read stacks of these forums and at am my wits end. I have downloaded JB umpteen times. Restored my atv a dozen times and tired everything from fresh more times than I can count. I’m running Snow Leopard 10.6.8. I cannot get my atv jailbroken. I did see the step (in another post) of how you should “right click” on the icon when you want to JB and I select the 5.3 option. Everything seems to be working fine until I get to the step that says “Restoring in iTunes. Please wait while script is running…”

I’ve waited…

I’ve cursed…

I’ve tried again from scratch…

I’m at my absolute wits end trying to get this friggen thing to work. Any useful suggestions out there? Please…

(I want to install the atv flash, but cant get past this 1st hurdle).:frowning:

PS I’m not on US hours. I’m on the other side of the wrld.

 

Since it looks like the ipsw is alreaday created you can just go into itunes and hit Alt+restore this will allow you to choose the ipsw you just created, use that and allow itunes to install that and you’ll be done.

It should be in users[user name]\documents\seas0npass\ or users[user name]\documents\seas0npass\downloads

also should be named AppleTV2,1_5.3_10B809_sp_Restore.ipsw.

 

notice the sp in there, thats the seasonpass file

Thanks for the suggestion Carpenter. Do you know where the ipsw file gets stored by JB? When I searched Finder I only found one copy in “Documents/Tether” folder. I restored using that, but didnt get the FC icon when I started atv in tethered mode. The file was called AppleTV2,1_5.3_10B809_Restore.ipsw. When I “getinfo” on that file it was last modified in Jun so no changes today (which I guess means it didnt finish or its not that ipsw file.) So atv still not jbroken…but i’m having delusions/fantasies of being closer!

 

Right- I dont have that directory or file in finder. Back to the drawing board…

I tried deleting the file (& tether directory). I reloaded seas0npass. It recreated the Documents/tether directory and the sames AppleTV2 file without the sp in the filename. It hung at the same step so I’ve tried to “restore” it manually again. I’m waiting to see if that works right now. Fingers crossed…

Didnt work. Still not JBroken.

I think there’s something fundamental amiss since there is no seas0npass folder being created and no ipsw file with sp in the middle of the filename. I’m trying to manually create the directories and see if the ipsw file will be written to the right place. No idea if it will work…:frowning:

I’m having the exact same issue. Hanging in iTunes. The script doesn’t seem to work. My ipsw file is being saved in the same location as you tasanchez5. The file name doesn’t have _sp in it either.

I attempt to alt/restore in itunes to manually select the ipsw file but eventually I get a 1601 error. Help!

If you’d got to the 1602 error then you’d be home and hosed.(At least according to the instruction video). The SP program def recreates the tethered directory. (i watched this time as it got to the Downloading AppleTV2 step. ) I keep threatening to give up but I just cant believe that other people can do this and I cant. There MUST be some way of getting this wretched stuff to work!

Try here:

Open finder, hold ALT and click on “Go” from the top menu. Choose Library and then the Application Support folder, go to Seas0nPass folder and then Firmware folder , check that you have file in there called AppleTV2,1_5.3_10B809_SP_Restore.ipsw

Sorry tasanchez5, the directory I told you it was in was for a PC not MAC, that’s why you didn’t have it. As far as your problem goes I came to my limit as to helping you, niceday1 seems to have a handle on it, I hope he or someone else will have an answer.

IT WORKED. NiceDay1 huge thankyou. Carpenter940 thanks also to you coz you twigged to what was happening. I am very very happy! Awesome guys. Thanks heaps.:smiley:

Finally got mine working. I was using that latest vesrion of iTunes (11.0.4) which was causing all the above issues. I changed to another mac which had an older version of iTunes (11.0.2) and it worked perfectly.

I’ve read through this thread and others and I just cannot get it. Like others, I get the hang on “Restoring in iTunes. Please wait while script is running…”

I do have the patched IPSW named AppleTV2,1_5.3_10B809_SP_Restore.ipsw – and I am able to perform a restore with this file using iTunes (as noted earlier in this thread). However, the Apple TV2 will not fully boot up. I get an initial apple logo when it is starting and then nothing at all (just a flashing white light on the front of the ATV

For now, I’ve restored the ATV2 back to factory settings (which I’ve done at least three times in the past hour in trying to get it jailbroken)

I’m running the most recent version of iTunes (11.04) and Seas0npass (0.9.3) on OSX version 10.8.4

Any ideas?

  • Bob

 

Sounds to me like you need to tether it. Hook it back up to your computer, click the “tether” icon in seasonpass and then it will be tether jailbroken. NOTE: YOU CANNOT REMOVE POWER FROM UNIT AFTER TETHERING OR IT WILL LOOSE IT’S ABILTY TO BOOT.

Thanks for the advice, but still “no dice”

Here are detailed steps I took/tried…

Starting with no SP patched IPSW restore file and an ATV2 restored to default 5.3 software and which has been booted under 5.3 at least once and “activated”. Note that the ATV2 is plugged into power for the entire duration

  1. Place ATV2 into DFU mode
  2. Launch Seas0nPass and use "Create IPSW" to create patched IPSW file (on OSX it ends up at /Users/[user-name]/Library/Application Support/Seas0nPass/Firmware/AppleTV2,1_5.3_10B809_SP_Restore.ipsw )
  3. Let Seas0nPass proceed until it gets stuck at the point where it wants to run the scripts in iTunes -- but doesn't
  4. Click Cancel button on Seas0nPass screen where it's stuck which returns Seas0nPass to the initial screen
  5. Launch iTunes and use "restore" button (with option key held) and select patched IPSW file for restoration and wait for it to complete
  6. Quit from iTunes
  7. In Seas0nPass, click on "Boot Tethered" button and let it finish up to the point where it indicates that it is safe to remove the USB cable

At this point, the ATV2 still has the LED flashing and it will not startup.

If I try to flip steps where I perform the “Boot Tethered” before restoring the patched IPSW file using iTunes – iTunes throws an error when trying to perform the restore (error 1600)

Thoughts?

  • Bob

 

So I had the most recent software on my ATV2 5.3 (6105) and i followed all of the steps and had to do it multiple times. I got the whole this working and istalled XBMC and started watching a movie. Then i moved my apple TV from my projector that i was hooking it up to right after tethering and then would try it on my tv in the living room and the ATV would turn on and show the black apple logo and then just sit there and continue to blink white on and off from the front and wont start. Are you saying there is no way to use the ATV after the power had been disconected? What happens if the power goes out? Am I missing a key step to this thing? Also iTunes version on my computer I am using is 11.0.4.4

 

Any help would be AWESOME! Thanks…

 

I guess i am new at this so any help would be appreciated… since this http://forum.firecore.com/topic/3418 says that 5.3 is “tethered” does that mean i’ll have to plug it in and run the “Boot tethered” option every time the power goes out from seasonpass? What a pain if so…

Yes. That is why people prefer an untethered boot if one is available.

A tethered jailbreak is easier to produce, so often the jailbreaking community do not work out how to do an untethered jailbreak for each firmware release.