Jailbreak 5.3

Hey guys, I recently brought an ATV2 and been trying the JB process with SeasonPass. All seems to run fine but when I connect to the tv it’s not JB, I getting access denied when trying to telnet to it also.


I checked the version on the atv2 when plugged into the tv and it tells me it is running v5.3? is it possible to JB this version and how?? please help I have spent a few hrs re-trying etc.

Your answer: http://forum.firecore.com/topic/3418

Thanks Andriod for the answer.

What a shame. Being new to ATV2 scene and developments, how long does it normally take for a JB to come out?


sometimes it can take as little as a week, other times it takes aslong as 6 months.

I hope it comes soon. Will keep an eye on these forums. Good resource

whether it is worth to wait for Jailbreak Apple TV 2 version 5.3??

new jailbreak untethered 5.3 now released        



ive downloaded the new seas0npass several times and i cannot open it with mac book pro .does anyone else have this problem


Havent seen anything stating this is “UN tethered”

I had no problems running the new SeasonPass, i’m using Lion 10.7.5



Current Apple TV version (released June 19, 2013)

5.3 (iOS 6.1.4 - 10B809) - tethered via Seas0nPass

And wait for the untethered??? worth the wait??

I’m running 10.6.8

I am tethered, but it keeps saying “No Device Detected”, which is weird since my Apple TV is connected.

It appears to be a tethered jailbreak so I went ahead and did it! Glad I did as I was running a very old version! Love some of the new features.

I am…Idk whats going on. A couple other people are having this problem as well. What Mac OS are you running? I’m running Snow leopard



I am having the issue where I get stuck at the itunes running script. But when I manually select the ISPW it wasy its the wronge version.

The ISPW seasonpass creates say 5.2. Is that right? Shoudln’t it be creating 5.3?

Is there any other mehtod to JB 5.3?


Thanks in avdance.



This is false information, please don’t post this again.  5.3 is tethered not untethered.  My version of atv2 was 4.4.3 until season pass updated my firmware without saving my shsh blob.  I warn anyone who uses seas0npass.  Be careful because it updates the firmware for you.  It ran on auto pilot and now I have to wait for a new untethered jailbreak.

I can’t get it into DFU mode.  It keeps saying seasonpass doesn’t support this version but it’s 5.3.

Please help

i started another thread http://forum.firecore.com/topic/10670 - basically unable to JB. Am using atv2 with latest IOS (5.3) and snow leopard 10.6.8

Have tried certainly everything i’ve read in multiple frums and no joy whatsover.

If any body HAS managed to JB their atv2 with the latest Seas0nPass with 10.6.8 on the Mac- PLEASE do let me know what you did. I’ve tried for 3 days solid. Fire Core support have not sent me any replies. I’m about to throw in the towel!