iTunes & USB Icons showing on TV After Completed Jailbreak

I have a Black ATV2 that I had previously successfully jailbroken to install & use the prior version of ATVFlash. Today I’ve been trying to upgrade to the new ATVFlash 5.0, so I’ve been following the steps to re-jailbreak with Seas0nPass as a necessary pre-install step.

After going through all the jailbreak steps all the way through the successful iTunes software restore, I plug my black ATV2 back into my TV, but the light starts blinking fast and the screen shows the iTunes logo above an icon for a USB cord.

Assuming I must have done somethnig wrong, I’ve repeated this process 3 times. I’ve even tried a tethered boot. But each time, the same result obtains.

Please tell me what I’m doing wrong & how to fix.

Thanks a lot,

Jonathan

jonathankopp@mac.com

I’m getting the same error… please post how to fix this

it is a tethered jailbreak rad up guys u have to boot it up plug in read instructions ..jail break first while plugged in then unplug usb while still plugged in and plug hdmi in ..use atv flash then http://www.ijailbreak.com/applications/how-to-install-xbmc-on-apple-tv-2/ once ssh in terminal then http://forum.xbmc.org/showthread.php?tid=127369