iTunes sees 0 space on External USB as Primary.

 Running all the latest stuff, checked the NitoTV files, all that good stuff. Got a 40 GB AppleTV with a 320 GB Hitachi SimpleDrive as primary storage external.

Finally got everything hooked up, but when I go to Itunes and hit sync, at first it showed the empty space (300 GB). Then when I tell it to sync, it tells me it doesn't have any space and the bar reverts to saying 0 KB free.

I've SSH'ed into the AppleTV, and the drive IS mounted, so I don't think that's the problem. I also tried to go to the Wiki which was linked to in several similar problem posts but the wiki redirects here. How do I make iTunes see the external HD's size so I can sync correctly?

Put me down for the same problem. I have tried both a 1TB drive and a 750GB drive, and the ATV reports only my original hard drive space while iTunes(also showing only the original hard drive space). says that there is no free space

 OK, slight update now: restarted the AppleTV via ssh (sudo reboot), and it seems to have allowed iTunes to see the full amount of space. Next it tried to sync automatically, which started working but it was syncing EVERYTHING. I stopped it, and selected what i wanted on the drive. Then hooked up via ethernet to sync and it gave me the "Apple TV is not responding - check port 3689."

 

After researching everything about this problem, I can't figure it out. Now iTunes sees the space and has no problem there, but EVERY attempt to sync gives the "3689" problem, even with the port enabled on my wireless router AND with firewall turned off on my computer.

 

Now I can't sync at all! How do I fix this 3689 problem?

 OK, one last update: I unplugged ethernet cable then put it back in. Now it's syncing...but it's almost as bad as being broken and don't know why - it's working and I don't know why! Still wishing to hear your ideas on why it broke to begin with.

Update to my earlier post as "anonymous" I made sure iTunes was not running and did a factory reset of the ATV.  I repartitioned the external drive I wanted to use so that I was sure nothing was on it. I then reinstalled ATVFlash, installed the NitoTV components, unplugged the ATV to make it do a restart, and then connected and chose external storage. This time it worked fine!

 OK, here's the update. Got it synced normally a couple times, but I think the external HD is spinning down to conserve power and this confuses iTunes. Can't sync now because it thinks I don't have enough space. Pretty sure this is due to the drive conserving power.

 

Has anyone tried an external drive that's powered instead of USB 2.0? I wonder if it would work better.

Some drives actually allow you to adjust the power saving settings with the included software.  Did your drive come with a software disc?  If so, you may check to see if there are any such settings.