iTunes scripts not running.. just hangs

I was able to create the IPSW and seem to get the device into DFU mode as it uploads files.  When gets to the restore in iTunes then it just sits there.  Looking in the SP_Debug.log fie I see thousands of the following line:

2013-02-23 12:22:48.809 Seas0nPass[972:af4f] iTunes window children count was less than 14, looping until 14 is reached.

Nothing else happens, just loops.

Any ideas?

I ran into the same problem that nothing happend when Seas0nPass should run the script.

What I did was to quit Seas0nPass. It has done its job patching the IPSW.

Then I Control-clicked the Restore button in iTunes and browsed to where the patched IPSW file was and selected that.

Voila! The ATV got restored with the patched IPSW and was jailbroken once again.


  • Running on OS X 10.8.2 and iTunes 11.0.1



Where was the location of your ipsw file?

Thanks! I was actually finally able to get mine working properly after I installed 6.1 from Apple and then tried to run SP again and everything worked first try.

It was buried in the user library: ~/Library/Application Support/Seas0nPass/Firmware

Weird, I don’t have seas0npass folder under Application Support for some reason. Neither the Firmware or the ipsw file. The only ipsw file I got was under tethering folder in documents. And it’s not jb when using that file.

Yep. That IPSW looks pretty standard. It was also the first I tried to use :)

But are you sure that you are looking in the User library and not the System library?

In OSX 10.7 and 10.8 the User library is hidden. 
The easiest way to access the User library is this:


  1. In the Finder, choose Go > Go To Folder. 
  2. In the Go To Folder dialog, type ~/Library
  3. Click Go.


Thanks lkodk! I was actually looking at the System Library actually. 

I ran this to unhide the User Library folder: chflags nohidden ~/Library 

And JB again, this time the seas0npass script managed to run all the way to the false positive 1602 error! And it was successfully jailbroken with firecore logo!!:smiley:

Hi there , I have the same problem, when running the script in itunes it hangs. I tried to control-click the restore apple tv in itunes but I can not click the restore button when I push the ctrl button?

So I can not choose the IPSW 

what am i doing wrong?


Hi, do you know why i cant ctrl click the restore appletv button in itunes?

i’m running itunes 11.0.2 and apple tv firmware 5.2


thanks 4 helping me out!

This is what I got to work with iTunes 11:

This is the solution I got to work, quoted from a response to another post:

I hope it works for you.

For those of you wondering why you can’t CTRL-click the ‘Restore’ button in iTunes on your Mac, try OPTION-clicking it.