itunes restore script problem



I`m having a problem with jailbreaking my ATV2 on 4.4.4. when using the latest seasonpass.


All goes well until Seasonpass opens itunes and attempts to run the restore script. Once itunes opens nothing at all happens. I tried googling around and I read somewhere that I can try to “shift restore” in itunes and use the custom ipsw file. I tried this out and it works from the itunes side, however seasonpass remains stuck at the running restore script in itunes part even after itunes finished restoring with the custom script. When I connect the ATV2 to my TV I do get the FC logo however I do not get any maintenance menu so I`m suspecting that despite having the FC logo I am not really jailbroken.

I also tried installing nito-tv or xbmc as a workaround but although i manage to get into the ATV2 using putty, I still do not manage to get the commands to work, I get this error:


Type ‘.deb’ is not known on line 1 in source list /etc/apt/sources.list.d/xbmc.list


Can someone help please? 


Further info: Windows 7 64 bit

Wireless connection

If the Firecore logo appears then the jailbreak with SeasonPass has worked.

If you now want the maintenance menu you need to run the FireCore installer (downloadable from your Firecore account).   This installer has a pre-requisite that the jailbreak process has completed successfully.  If you are not using the FireCore software then you need to google for ways of manually installing items like NitoTV, XBMC Plex.


Thanks for the reply, but there is still something i cannot understand:

From the instructions:


Step 6: iTunes will confirm the restore when complete - your AppleTV is now jailbroken!

Note: To confirm the jailbreak was successful a (temporary) red FC logo will appear in the lower right corner of the screen - as shown below.


My FC logo doesnt seem temporary as I have no way of removing it, am I missing something? I am still not fully convinced that the jailbreak worked correctly because as I mentioned I get errors when I try to SSH and also becuase seasonpass never closed or said that it was ready during the jailbreak process…I had to close it myself whilst it was still displaying that its restoring from itunes.

Is there a way to check that the firecore installer would really work? I am reluctant to pay for it when I suspect that it wouldnt work because SSH isnt working properly.

If you see the red FC logo you can be assured the jailbreak was successful.

This logo will be removed when installing any 3rd party software on the AppleTV.


Thanks, solved, all working now, I solved the SSH command problems by following these instructions: