"iTunes restore script failed"

When I try to jailbreak my Apple tv I get this message in seasonpass  Can someone tell me what I am doing wrong?

I get the same thing, 11 or 12 times now.  “ITunes restore script failed!, selecting IPSW in Finder”

OK.  After trying most of the suggestions, I purchased a new micro USB cable (Radio Shack Gigaware gold plated).  The procedure documented in Jailbreaking 101 still failed with the same message, but this time I was able to go into Itunes, press Option (on an Imac, I think on a laptop the the shift key is used) and click Restore, then select the ipsw file that was created by OpenSeason.  Itunes opened a message box to ask me if I wanted to restore the Apple TV. I clicked yes and this time with the new cable it worked to completion.

Are you running the latest 0.7.7 version of Seas0nPass?

Yes I is the current version, just double checked

Me too…

MacOSX:  10.7

Seas0nPass: 0.7.7

There’s a workaround for this problem found in the thread below, but if you’re able to send in your log we can try and track down what’s going on.

 

This workaround worked for me.

Thank you for support team.
I’m ok.

Best regard

What worked for me was to disable “Full Screen” mode for iTunes on OSX Lion. It turns out that when you run an application in Full-Screen mode on OSX Lion, the Window cannot be called anymore, so Seas0npass couldnt call for the “iTunes” window anymore… Hope this helps some of you…

Give this man a cookie.

Also of note: if iTunes is open, you need to make sure you’ve closed it after exiting fullscreen, since Seas0npass will terminate the program, and won’t save your “fullscreen” preference otherwise. So as a result when Seas0npass re-opens iTunes (even if you left fullscreen) it would re-open to fullscreen.

Seas0npass Devs: Take note. this should definitely be in the wizard since a lot of us are on Lion. (unless you can add an exit-fullscreen in your script, or target in some other way)

Thanks for an awesome product fireCore folks!

Sleuth!

This issue has been resolved in a new version of Seas0nPass (0.8.1) that was just released.

 

Actually, I don’t think it has been resolved. I’m experiencing the same issue right now. iTunes is always launched in fullscreen mode (whether it’s already open or not) and the jailbreak fails. People are suggesting that you disable fullscreen mode for iTunes but where do you do that? I don’t see any options in iTunes to do this. Any help would be appreciated.

Sidenote: once the patched ipsw file has been created, can I just manually restore from iTunes with the file Seas0npass created?

Are you running the 0.8.1 version of Seas0nPass? (check version through the About menu in Seas0nPass)

 

Yep. Version 0.8.1 (330)

Just grabbed it this morning.

Hmm - would you mind opening a support ticket and sending in your SP_Debug.log file (locate by selecting the ‘Show Log in Finder’ from the Seas0nPass > Help menu).

 

Actually, this last time I tried switching to ‘mini player’ mode before quitting iTunes and ran Seas0nPass again and it worked! Not sure if what I did had anything to do with it or if it was just coincidence but it did work. Thanks for your help!

 

That would be both a Yes and a No :slight_smile: Yes, it had to do wth the fact that you switched to mini player before you quit, but also No that it wasnt the process that would’ve been the recommended way. When you’re in iTunes “Full screen” mode and move to the top menu-bar, on the extreme right will be a small blue button with two arrows pointing inward. That’s OSX 10.7’s new “Full Screen” button. Press that and your iTunes window should “pop out” making it non-Fullscreen. Next, quit iTunes completely (make sure there’s not a small white circle under it anymore in your dock (if there is, Right-Click and choose Quit)) and start iTunes up again to see if it goes into Fullscreen mode again. It shouldn’t. If it doesn’t, then relaunch Seas0npass and everything will work wonders… FYI, I didnt test this on the very latest version but judging from your experience, it should be exactly the same…

I am having the same problem. I have tried it in both mini-player and regular window, but it always fails. When it is in the regular window, it always enlarges iTunes to fullscreen, and then the script fails. I have also filed a ticket with my log file.

After swapping USB cables and ports for three days I couldn’t seem to get past the iTunes restore script failed!, selecting IPSW in Finder… error! Seas0nPass would get up to the stage of restoring in iTunes and then fail with this error but the following steps worked for me.

  1. Restore your ATV2 in iTunes (use Apple's firmware)
  2. Adjust your hosts file using the instructions here
  3. Reboot your laptop
  4. Fire up Seas0nPass and run through the steps (don't do anything else during the entire process)

Hopefully this helps others!

How do you adjust the hosts file on Mac? I’m lost on this one!!