iTunes Restore Errors

Error 21, 22

Apple TV is not in DFU mode. Re-run Seas0nPass to ensure the Apple TV is in DFU mode before restoring in iTunes.

Error 1600, 1601, etc...

Often times these errors will be false positives. If you're seeing one of these you may simply try connecting the Apple TV to your TV to see if the red FC logo appears in place of the normal settings icon. As long as the red FC is present then your Apple TV has in fact been jailbroken.

If no red FC logo is present then you can try the tips below.

  1. Ensure all other iDevices (iPods, iPhones, iPads, etc...) are disconnected when restoring in iTunes.
  2. Connect ONLY the USB cable. Power, ethernet, HDMI, and optical cables should remain disconnected.
  3. Try using a different USB port and/or removing any USB hubs.
  4. Try an alternate micro-USB cable - a good, low cost cable can be found here.

Error 3194, Apple TV is not eligible, etc...

Apple is no longer 'signing' the version of Apple TV software you are attempting to restore. Update to the latest version of Seas0nPass to jailbreak and install the latest Apple TV version.

If you're certain the latest version of Seas0nPass is being used, then unfortunately there may not yet be a jailbreak available for the current Apple TV software. Check the version info page for more details.

Other errors

Full details on these as well as other iTunes restore errors can be found here.

Thanks for your help so far.  

I followed your above advice and fixed problems with a 1600 Error, then a .NET error (using Windows 7 (x64)), then a 21 Error.  

I am at the stage of restoring in iTunes following download (and patching) of the IPSW file.  I now have iTunes giving me an "Unknown error occured (14)" problem.  Any tips on this one? 

I am having the same problem "Unknown error occurred (14)". It seems that this is not all that uncommon, any help would be really appreciated.

I was suffering from a 1601 error.

Just tried the install again today, without changing anything, and it worked!


Error 1600, 1601, etc...

  1. Ensure all other iDevices (iPods, iPhones, iPads, etc...) are disconnected when restoring in iTunes.
  2. Adjust 'hosts' file to allow it to communicate with Apple's servers instead of Cydia (details below).
  3. Try an alternate micro-USB cable.




After 3 days and several attempts I´m still suffering from a 1601 error even though I clearly followed above instructions.

Does anyone have had same issue and did you manage to resolve it?

It seems that the trick is to try over and over until you get lucky. I´m not among the lucky ones however...  :(

FYI I´m on a MacBook using latest version of ATV 2 4.2.1 (iOS 4.3) + iTunes (10.2.1) + seas0npass ( + no devices other than ATV 2 connected to my MacBook + unchecked the 'Set Hosts to Cydia on Exit' box on TinyUmbrella + closed both TinyUmbrella & iTunes before restoring iTunes + tried 2 brand new micro USB cables.

Thanks in advance for your help!


Details on other possible iTunes errors can be found here.

I had 1601, 1602 errors too.


Remove the power cord and leave the ATV2 unplugged while restoring, just the usb cable. this helped me finally

Apple tv will not complete restore process via itunes. It gets to about 98% completion but then does not move, it has been frozen for over an hour. Atv is only plugged in via the micro usb, also tried it with the power cord nothing changes. The atv2 is stuck on dfu mode, this all started after trying to to JB with season pass 4.3.1 untethered.

As mentioned before, try using a different cable as it might be the culprit. Try restoring to the standard Apple firmware in iTunes (don't use shift+restore). iTunes will download the latest firmware and reset the ATV2 to factory defaults. If this works, the cable is fine. Unplug the ATV2 and restart the untethered jailbreak process as illustrated in Jailbreaking 101.


When u say a different cable, you mean a different micro usb cord, right?

I had previously tried the normal/regular restore and update from itunes, same results. I will then purchase a new micro usb cord.

I'm failling on 1600 in iTunes as well well when I try to restore the SP image.

I can however do a normal "Restore and Update" and it completes normally. I've noticed that when I do a manual restore, the ATV2 disconnects and reconnects twice which I can tell from the Windows USB disconnect and connect sounds. Each time it disconnects, it reconnects and remains in DFU mode. When I to a factory "Restore and Update", the ATV also disconnects and reconnects but it does it three times. After the first disconnect it recconnects in Recovery Mode. On the second reconnect it's in normal mode and on the third reconnect it's in Recovery Mode again.

I've checked the hosts file and cable. I'm running iTunes on Windows XP SP3.

Please help!


The restore worked with windows using season pass, each time i tried it on snow leopard it would time out.

I was having the same problem ! whilst it was at the 98% mark i opened TinyUmbrella and bang it finished and is working ????

If u cant go in DFU then put the Power Cable in it and it works;)

Those of you who switched cables, can you post what you used that DIDN'T work and then what you switched to?

I bought some POS from Best Buy.  It is made by Datapilot  and it is a multi head cable made for LG/Motorola phones.  I'm getting issues and now I'm going to get another cable.

Knowing what worked would be awesome!

Update:  I bought a new generic cable the other day.  It's description is an, "18" Gold Plated USB 2.0 Type A male to Micro B Male Cable, with Ferrite Core."

Initially it didn't work either.  Then I switched to the USB port on the back of the computer (directly on the motherboard) and it worked fine.

Good luck everyone.

This is my third try to get help – now over the forum. In the first two i used the support form and just get a standard answer "please look at forum thread blablabla".

That's what i did before and after, but i still have the same problem: THE JAILBREAK DO NOT WORK!

Meanwhile i am a DFU-Expert, but always when i try to restore the modified Firmware, i get ERROR 14 after a few seconds of the restoring prozess of iTunes.

I have tried it with my MacBook Pro and an Toshiba Notebook with Windows XP.

Restoring the standard firmware software using the same cable/iTunes works perfect!



After buying a news USB 2.0 Cable and updating the seasonpass software to the latest version and reinstalling iTunes i STILL HAVE THE SAME PROBLEM AND NO ONE HELPS ME SINCE ONE MONTH NOW. Im really pissed off about this piece of s*** and the poor support!!!

Hi! I accidently renewed the iOS software of my TV in 4.3 version unti then the box worked like a dream.(jailbroken with Greenp0isen)

I tried Seas0nPass to repair the box, but i am receiving the error message: iTunes restore script failed, selecting IPSW in Finder...

Any ideas to restore the MagicBox?

Regards RinusRups



I was having the same problem ! whilst it was at the 98% mark i opened TinyUmbrella and bang it finished and is working ????



Sounds like Apple restore is checking the apple servers a few times during the restore process.  Thus why we should avoid a jailbreak that requires TINYUMBRELLA or the HOSTS file.  Hope the latest version of SEASONPASS does not need anything other than a working USB cable (as proven be a full restore via ITUNES, pre-jailbreak).