iTunes not recognizing ATV

Is this an iTunes 10 problem, or a ATV update 4.1.5 problem?

The ATV is completely missing from my network…movies can be rented (so it appears to work just fine) but no syncing with itunes since it doesn’t recognize the ATV, and also the remote apps no longer identify the ATV on the network (using Apple’s Remote and also Remote HD).

Who else is experiencing this?

Same problem here.

You may try one of the troubleshooting tips here: http://support.apple.com/kb/TS1453

Hi
I have the same problem: upgraded to ATVFlash 4.1.5 (on ATV 3.0.2 and iTunes 9.2.1.5) and have lost the ability to synch with iTunes. I can access all the content that is already on the ATV and can access the iTunes store from ATV. I can also FTP to it using the IP address (though the name AppleTV is no longer resolved).

I have powered on/off several times, changed the wireless connection to an ethernet wired connection, without success. I have followed the Troubleshooting AppleTV (except re-installing iTunes) without any luck.

I thought that there may be a firewall issue, but turning the firewall off temporarily also didn’t work.

Any thoughts what to try next?

Thanks

 Some closure on my issue: Upgraded iTunes to version 10, performed a factory restore, successfully linked ATV and iTunes but was not able to synch still. Turned off McAfee firewall completely and synch was possible. Turned on Windows firewall with port 3689 enabled, and synch was possible. Then upgraded to ATV 3.0.2 then re-synched iTunes media. Installed ATVFlash 4.2 from USB stick. Had to set iTunes media to 'External', then change it back to 'Internal' for my existing media on the external USB drive to be recognised.

Basically got it working, looks like my issue was caused by an auto update of the McAfee Security Centre on 31 July, although it is not clear why it stopped working as it was working beforehand, had the port 3689 defined and still works with the Windows firewall.

I'm now not able to synch up with itunes.  I've tried everything on apple support site for this.  I've turned off firewalls.  I've restarted and unplugged and then re-restarted everything. Reinstalled Itunes.  It won't even see the ATV.  I uninstalled and downgraded to itunes 9.something - I at least got a tab next to devices that said the word apple tv but it was just blank.  I DO have mcafee running but not the firewall option (using the windows one which I've shut off, and also shut off the router firewall)  Its a 2wire if that might help. 

I finally cut the link from the 'Computers' on the atv as the top option had been grayed out (it may have been before?) and now the itunes white, and at the top, and then i have the line below to add itunes library which both give me the code to give itunes....still no success.

I CAN though, still play networked media from my pc (ethernet connection though I also tried wireless to see if that would help) thru xbmc and nito.  I can play itunes trailers (have not yet rented a movie) and internet etc all seem to be working.  Just can not stream music to itunes on the atv.  Any other suggestions? (I did just extend my membership as well in case i need to do a factory reset but i really don't want to do that again as I've had to do it many times).

Thanks in advance

Tried factory restore , nothing...then reinstalled atvflash, nothing.  Was able to watch a movie via the atv with no issue last night.  Just am out of ideas and would appreciate anyones advice on what they've tried? FTP works as well.

I have the same issue. Can play back all my synced media but the ATV does not show up in my iTunes device list. Hey Firecore, how about a little more help here instead of a useless link to Apple?