iTunes Match stops working after one song

Every since I updated the software, iTunes Match has been extremely buggy. After playing the first song of an album, it just cycles through the rest of the songs on the screen quickly without playing anything and then stops. When I click on another song to play, I get the message “iTunes is currently unavailable. Try again later.” And that’s it! If I try to reboot, I have to do a tethered boot to get it back. And then I can play one song again before the same thing happens again. It’s extremely frustrating! Any solution to this?

I’m having the exact same problem. Any solution yet?

 

I have the same problem too.

After updating my apple tv to 5.3 (untethered), i have the same problem with itunes match. The only difference is, that i can reboot the apple tv without the need of jailbreaking it again, because i already installed the newest update (5.3 untethered). Is there any solution for this iTunes match problem? 

I’m having the same issue since upgrading to 5.3 and using atvFlash Black 2.4. There were no issues before this update.

Ah crap on a cracker, WHY couldn’t I have seen this freaking post before I updated?? The problem is still there, nothing has been fixed and clearly iTunes Match has been broken for 2 months.

This is GD ridiculous. 80% of my time on my Apple TV is playing music through match.

Support suggested I upgrade to try and fix a problem with Infuse, so I did. Not only is the problem still there, but now I’m unable to use match.

FFS.

Add me to this group. It’s pretty annoying. As a workaround, I’ve been playing music on my iPhone and using AirPlay to play it on the ATV. Hopefully someone at FireCore can address this as known issue.

I’m really frustrated that they’ve not even addressed this.

still no fix or workaround!?

Anybody submitted this as a service request to FireCore?

Same problem !!

Submitted a support request on January 8th, first suggestion was to log out/in to ITunesMatch, still the same problem. Did a bit of further investigation myself and noticed tracks 1. 10, 11, 12, etc. play, i.e. track numbers with a 1 in them, found some other patterns too on albums sets with 30+ tracks. Sent this information to Firecore support hoping it might help to fix this bug. Firecore thanked me and said they would see what they can do! Still waiting, very disappointed that Firecore Support have posted no replies to the people who have posted to this support forum.

ok, one user more.

I´m so dissappointed. With 5.0.2 no problems. Now with 5.3 only the first title starts.

I recognized that this has nothing to do with infuse. i jailbreaked it now three times and directly after the jailbreak i logged into itunes match. So, it seems that the jailbreak is the “bad boy”

But whats next? All the music stuff for my daughter is there and this is a major bug.

Is there in the meantime a solution? I have also opend a request.

streimers

If the jailbreak is the problem then it is possibly more useful to make sure that the issue is raised on the jailbreaker’s sites/forums. FireCore merely package their jailbreak so I do not know if FireCore are the best route for resolving jailbreak issues.

you are absolutly right! But…

There are so many websites and i´m not sure to find the right one.

Who has better communication ways than you. Nobody, really nobody, because the jailbreak is a requirement using atvflash. This is a seas0nPass jailbreak and so i think that this forum is the perfect location to talk about this issue and to search for a solution.

Many people have this iTunes Match behaviour, so plz talk with the jailbreak community. Without iTunes Match the ATV2 is useless, so i have deinstall the jailbreak and also to deinstall atvflash. 

This cannot be in your interest.

Thanks for your support

streimers

I am not FireCore - just another user!

I was just pointing out that I am not sure how much is being said to the orginators of the jailbreaks so that they know about the issue.  I would hope that FireCore pass on such reports but who knows!  Also, I do not know how reproducible the issue is and if everyone gets the problem or if it is one of those that if you get it it always happens but for others things work fine (which makes them harder to debug).  I personally do not use iTunes Match so am not in a position to comment on that.

I didn´t get an answer regarding to solve this issue, so after three times using the jailbreak 5.3, i switched back to 5.0.2.

Unfortunaly, this was the last saved SHSH Blob FW Version. But now, all is really fine. iTunes Match works great. The other 5.0.2 features also. aTV Flash 2.4 works as desigend.

I cannot understand why there is absolutly no statement from the jailbreak community. Perhabs there is a bug for only a few users, because you have to use the 5.3 jailbreak, using a ATV2 and using iTunes Match. But it is really sad not to know if someone is working on it or not.

Greetings

streimers

 

 

I’m having the same problem since upgrading.

More info - 

I submitted a trouble ticket, waiting to hear back.

 

Typically the first song I select from an album or playlist is often played fine, then it skips through most or all remaining songs on an album or playlist, with an unreliable exception: 
I’ve noticed today that if another song from the album or playlist does play, it appears to be an unmatched mp3 file rather than a matched AAC itunes format file. If I don’t mess with it it seems to continue skipping matched AAC format files and continue playing any further unmatched mp3 files. If I do try to skip ahead or back, sometimes it will continue on to find the next mp3 file, but it’s just as likely to give me the "iTunes unavailable…” message. Going back to the original song that I selected in the album/playlist, or onto another album/playlist, often results in the "iTunes unavailable…” message too, and once the message shows up it continues for some time regardless of what I try and play.
When the song skipping starts, sometimes the song skipping happens slowly, with the circular waiting thing for 10-20 seconds, seeming like it's trying to play the file, but sometimes the song names skip by quickly.
My network seems fine, all other computers access internet fine, match works fine via itunes on the computer.
I’ve restarted apple tv, logged out & back in to itunes, turned match on & off, turned off/on dolby digital, restarted cable modem & router. AppleTV is networked via cable.
What is seeming consistent is the skipping of AAC matched files beyond the first song I select to be played. Beyond that, t’s not consistently playing all unmatched mp3 files, but those appear to be the only ones that have a chance at being played, some of them are skipped too.

After searching for hours for the culprit, i’ve finally found him here…

A very annoying problem, indeed!!!
Please Firecore, get to this as quickly as possible and deliver a bugfix release asap. Almost 800 views for this thread as i write, so take action!

Bump!