iTunes Error Code 9

Hello all,

I keep receiving error code 9 from iTunes while trying to jailbreak an Apple TV 2 that I have. This code is usually related to the USB cord failing to connect with the computer, however it connects fine, shows up in iTunes and then eventually gives this error message during the restore process. I have tried multiple cords and different computers with the same result. I have jailbroken numerous ATV 2’s, so I am thinking it may be the Apple TV itself? Or maybe there is something else I can try to get this Apple TV restored and jailbroken. Any help or insight is appreciated, thank you.


if the light is flashing rapidly when the power cord is in the unit is bricked(hardware failure)

the light is normal, not rapidly flashing. Everything seems normal with it even through the restore process, just eventually get that error code 9.

if you plug it into the tv and c the itunes symbol with the usb cord it’s bricked

It can still be jailbroken to 5.0.2 through itunes, even if it shows this message.

I had 3 of these at the weekend, all with the same message as you’ve stated above, and all fixed.


Use ireb to get into DFU mode, then run itunes rather than seas0npass, hold shift and click restore apple tv and select the SP ipsw that shows up in the downloads folder of Seas0npass.

It does work as I’ve bounced these back from the Itunes logo to jailbroken fully working.

Try a different PC or USB port.


Dave, stop bsing you were in the itunes fourm a few weeks ago asking the same question and having the same problem. Now all of a sudden you got error 9 to work by just plugging it in and putting the unit into dfu mode complete bs.

what’s is likely you simple had 3 apple tvs that were already in dfu mode that 's why when they were plug into the tv you simple saw the boot symbol from itunes.

The OP clearly states he had  plug the unit into MULTIPLE computers with multiple usb cables trying to restore and  he’s getting the same error(9) this means the unit is bricked and it’s done. sometimes you can get it to restore but after a short time you will wake up and start it up and you will c the same boot menu on the tv screen.

Itunes Error Code 9, no one can fixed it. the unit is brick.

1 Like


The itunes forum? the only itunes forum error I asked about was with ATV1 with the infinite loop.


If you mean this 

I resolved the -1 and -9 error which I kept getting, if it was the Itunes logo with the micro USB then yes thats what I got, I did try on multiple pc’s but finally got it working on my acer revo.

If it was DFU mode I was in, then sorry I may have misread, but Ive got through it, 


Ah I see what one now

So my error -9 was complete and utter BS? right ok

You are right.

I have used 3 different methods still don’t work!