iTunes 11

Hi, I got the same error - at least I was able to restore back to the official apple settings by following the guidance from apple re. error 1604 (wait till error happens, click OK, close and restart iTunes while keeping the apple TV connected via the USB and run the repair (w/o shift to apply the official apple software repair/update). But when trying to manually apply the Seas)npass software update aftewards the error returned. Any solution for this?

So I get to the point where iTunes tells me to unplug my ATV2 and connect it to my TV.  The Seas0npass window says Please wait while Seas0npass is running a script.  The green status bar is full, and doesn’t appear to be moving.  I am not sure how to proceed, I waited for about 30 min in that state, then unplugged the ATV2 and plugged into my TV… Went through setup, no FireCore icon.  I am on PS with Windows 7 Ultimate 64 bit, any insight as to what I’m doing wrong?


Edit, got it, had to use an older IPSW.  

I can find the file Seas0nPass built and I can restore, after the restore i plug it back into the TV and it is not jailbroke. Also Firecore says AT2 is not jailbroke. I am using a Macbook pro and itunes is 11.0.1 using Seas0nPass 0.8.6 (565)

Please advise on how to proceed.

FWIW, I just went through a painful few hours.  Couldn’t get this to work, then bricked the ATV, then recovered, then got it jailbroken successfully.  The issue in the end, was to use a different USB port.  

So, it worked for me.  Used ATV 2G which had software 5.1.  Comp has Windows 7 64 bit, and Itunes 11.  

Thank you whomever wrote this software.  I can’t wait to put XBMC on my apple tv.  

At my wits end. I have used all ports with no success. I have tried older ipsw’s, shift restore turned all security off, etc. . I have jail broken this atv 2 before with success but with great regret upgraded to xbmc frodo. This froze my atv2. So I decided to do a fresh restore but I can’t jailbreak now. My worst nightmare coming true. Any more tricks. Using win 7, iTunes 11.0.1, atv 5.0.1

Update: right click ipsw to 5.0.2 and LEAVE IT PLUGGED IN THE WHOLE TIME. This was my answer. Took many hours to realize this.

Seas0nPass 0.8.8 is now available which restores automated scripting in iTunes 11.

where is the link to the new seasonspass 8.8??

or is it just the download is the new one?

I attempted to jailbrake my ATV2 all weekend using my macbook pro. I have a windows 7 pc at work I downloaded older version of iTunes and it jailbroke the first attempt.



Same link as before (see my post above). You should also be prompted to update when opening Seas0nPass.

It worked for me after doing it a second time.  The second time around it automatically found the file in ~Library/  etc.

Thanks a million:-)

Hi everybody

I have a problem whit the jailbreak.

I’m using the latest seasonpass and Itunes 11.1

After seasonpass opens Itunes automaticly seasonpass gives an error (seasonpass sudden stops)

seasonpass program is than closed and nothing happens in Itunes.

Can someone please help me


Are you clicking any buttons in iTunes, or just letting Seas0nPass handle everything?


I’m letting SeasOnpPass handle everything.

everything goes ok, but after opening Itunes automaticly SeasOnPass sudden stops

Running fine 11.1 with new seas0npass, just run seas0npass to get the new ipsw, then ireb it in to DFU mode then use shift and restore in itunes

Works fine now, no issues

it’s working now.

very strange but Itunes was on fullscreen mode.

after changing that jailbreak was succesful.

but now i want install atvflash back, but this does not work.

it shows installation successful but no changes appear on Apple TV.

Does a new “Maintenance” box appear on the second row? if so go to there, thats where you install everything from, when you originally set to use ATV Flash black, was the Firecore logo showing over the Settings button?

If no to the firecore logo, reboot, if its not showing, re-jailbreak, you shouldnt need to use Seasonpass again, just get it to DFU mode with ireb, and run it from itunes.


Yes thank you i had to install it in the maintenance box.

and its working now.

Tanks allot for your help

Hi James

I have spent the last couple of days trying to update my Version 2 of Apple TV after a friend told me how good FireCore was and reading the website.


I am running a MAC (Mountain Lion) with iTunes 11.0.1 (12).

My Apple TV is version 2 (MC572X/A) and running 5.1.1 (5433) iOS.


I have downlioad Seas0nPass Version 0.8.8 (615) and let it run through it’s updates.

I have tried connecting my apple TV using different USB ports (3 to choose from) and used differnet USB cables, and followed the different instructions, BUT I have NOT had the apple TV connect to iTunes on any occassion, and the Seds0nPass sits and waits with a message “Waiting for device to ener DFU mode…”.


It sits here and does nothing, even pushing the MENU and Play/Pause buttons on the remote (changes remote light flashing) but nothing on the MAC.

In Seas0nPass preferences, it only has “AppleTV2,1_5.0.2_9B830” in the Fireware Version dropdown.


I can’t find where I can go back to any earlier versions of iTunes, and can’t get back to any earlier version on Apple TV.

So, this has been a waste of countless hours over the previous 3 days.


I want clear directions how to either restores software levels, links to them, or a level of your software that works!

Wow, mighty demanding for free software aren’t thou.

First off you need to put the device into DFU mode as it says. To do this you need to hold Menu + Down Arrow and when the Apple TV turns off immediately you need to start pressing Menu and Play/Pause. (If you’re doing this with the Power Cord plugged in then once the device is in DFU mode you need to unplug it.) (This is all assuming the device is in a powered state. If it is not then simply hold Menu+Play/Pause and plug the USB in.)

Next make sure to download this IPSW:,1_5.0.2_9B830_Restore.ipsw (this is the last iOS version that can be untethered. Note that since Apple has released a bunch of subsequent versions the signing of this specific version may stop working and once that happens you will only be able to restore the latest which is a tethered jailbreak currently.)

Once the IPSW is downloaded open seas0npass hold Shift and click Create IPSW. Point the Finder to where you downloaded the IPSW and let it do it’s thing.

Solved how to find the hidden restore file:

I struggled with finding that darn hidden version of the restore file.

In ML the file is hidden and you cant see it even if you turn on the show hidden file commands.
I used “Find Any File” which is a free app.

Performed the search for AppleTV2,1_5.0.2_9B830_SP_Restore.ipsw

Found it and it then could be opened in finder and copied elsewhere.