iTunes 11

Unfortunately iTunes 11 has broken some of the nice automation scripting in the current version of Seas0nPass.

An updated version of Seas0nPass is in the works, but for now a workaround for using Seas0nPass with the new version of iTunes can be found below.

  1. Run Seas0nPass normally through where the script error occurs.
  2. Locate the newly created IPSW file (named AppleTV2,1_5.0.2_9B830_SP_Restore.ipsw) On a Mac this will be located in the ~/Library/Application Support/Seas0nPass folder. On a PC it can be found in the /Libraries/Documents/Seas0nPass folder.
  3. Open iTunes, and select the Apple TV in the lefthand sidebar.
  4. Manually select the firmware file that was created by Seas0nPass. This is done by holding Option and clicking the Restore button (Mac) or holding Shift and clicking the Restore button (PC).

Update 12/18: Seas0nPass 0.8.8 is now available which restores automated scripting in iTunes 11.

Only problem is the folder is hidden so you cant path it when you try to manual restore!

There are 2 ways around this, both involve relocating the IPSW file to a different location (such as the Desktop).

  • When the restore script in Seas0nPass fails, it should automatically open the folder that contains the IPSW.


  • Hold option and select the Library item from the Finder's 'Go' menu, then navigate to the proper folder.

It does’nt default to the location. Also the library folder is a hidden file type when you go thru the itunes manual restore. I did indeed make a folder of my own and copy paste the ISPW, Got it all to work. thanks!

Once software is downloaded and DFU mode is found, finder opens with a fail and computer freezes.

Sorry none of the above works for me. The SP ipsw file is a no show in my folder. Wish it was there visible or invisible… Attached is a screen shot. I tried downloading and installing an older version of itunes. Same problem occured it seems the issue of file patching is prior to itunes???

Checked the SP Package Contents to see if I could ipsw unzip the file myself to access it. I could not find it specifically. 

any ideas?


This issue is actually not related to iTunes 11. You may try one of the Mac specific suggestions found here.

i followed these steps and get erroe message 1604 any ideas?

When doing this, I get a 1604 error.

Anybody a solution for this?

i got error 1602

and i fix that  whid this


I had to revert to iTunes 10.7 to work.  You also need to delete the latest library.

Does this workaround work for itunes 11 for sure? can someone confirm this? I made a bad mistake by upgrading to itunes 11 yesterday and didnt like it at all.  I have to figure out how to change the view back to the old look.  once i do that i will try jbking with itunes 11.  I tried it a few times yesterday and it kept getting stuck on scripting. i will try the work around today… any moer advice would be great…  thanks

Yes this work around works on Itunes 11.  Im running OSX Mountain Lion with Itunes 11. What you need to know though is when the script error comes up it pops up the ISPW window in finder. Do NOT use that one when you have to manual restore in Itunes. You need to find it under the location shown in the work around post above. I could not see it in the finder folder when I did the manual restore, but when I opened the finder folder thru OSX I could see it so I just copied it to a easy to find folder for ease.


Hope this is not confusing, Im not to good at typing computer instructions. 

ITS a liitle confussing the way you say it…  but  i am using windows 7.  what happened to me is it kept getting stuck on some bar graph that said something like “please wait while copying script”

what do i do at that point?


Oh sorry. In MAC “Finder” is Mac version of windows explorer. Sounds like a windows issue. Not surprising. I work on a Windows workstation for my job and always get errors. At home on my Mac smooth sailing. Not to get on that debate but it might be some windows coding. I would try reboot then try again

but when I opened the finder folder thru OSX I could see it…


what is that similar to in windows???

when the script error happens what do you do??? can someone tell me ??




You just said you were suing windows 7 , now your on OSX? Im confused. 


Finder in Mac is similar to what windows explorer is.


Script error happens. click on the itunes restore button while holding down option key. Then find the IPSW file in your applications folder. Done

i was quoting you there… im on windows…

i got ya now…//

what is the options key??? the windows key?  i thought on pc you hold shift and restore and it brings up the finder box to manually find the ipsw file…



You’re correct shift is same as option. Should work just find the correct IPSWfile not sure why there is 2 of them, but one in tethered folder is NOT the one you want to select to restore

I did this ( with power cord in - to get in dfu mode  -  and left power cord in -and when stuck on script bargraph i did a shift/restore and located the new seasons pass  ipsw and did the update.  it ran through most of it but got stuck on the final stage saying either updating apple tv or restoring apple tv…  and just stayed there…  i left it for about 10 minutes and eventually got the 1602 error -  finaly just unplugged it and tried it and it was jail bkn with the firecore logo on the settings icon.  and all works…

i did not get the message at end saying " your apple tv has been restored "

very strange…  is this normal to get the error and then it works fine???