Itunes 11

Im trying to jailbreak my atv but it apears to be having trouble running to script to restore the atv.  Im wondering if it has anything to do with the update to itunes 11(windows 7) that took place yesterday.  

Same problem here. iTunes 11 on Win 7. I get to the point where iTunes opens up, but it doesn’t auto restore, so I hold down shift, then click the button to restore in iTunes to do it manually, then point it to the .ipsw file with the SP in the file name in My Docs\Seas0nPass. So then it starts to go through the restore process in iTunes, however it errors out after a few minutes with “The Apple TV could not be restored. An unknown error occurred (1604).”


Any ideas? Thanks in advance!

Just purchased last night.  Same issue here with iTunes 11 (mac) and restoring aTV file…will not work, get an error message from iTunes.  Not looking good for a first run at this new software…was always nervous about trying to “jailbreak” any of my Apple stuff and am wondering if I just made a HUGE mistake!!

Help Please!!


Todd T. 

Just go find a copy of an older version of itunes 10 and use it.  That worked for me.  The script will run fine.  How ever, once you get finished itunes is going to throw an error saying the restore couldnt complete.  I have found online where for some it worked and for some it hasnt.  For me it didnt work the first time, but did the second.  After that, continue jailbreaking with firecore as normal.  Hope this helps.

Please see here for a workaround.