Issues with new Remote HD (5.0+ compatible)

I am jailbroken on AppleTV software 5.0.1.  And, well, good news: I checked Firecore’s Maintenance app this morning, and “Remote HD” is now being offered again.

I see @firecore mentions it on Twitter as well:

Once installed, a new button for “Remote HD” appears on the home screen. Click it – and all that is in there is the version number (4.4) and a menu command to “Hide Menu Item.” Bad news, however: if you select that, all it does is hide the version number.  The button (now even more useless, as there’s nothing displayed when you click it) does not get hidden from the Home Screen.  Also, I see no way to “unhide Menu item,” either.  And rooting around in .plist files isn’t getting me anywhere!  Ack.  Is there any way to get that version # menu item back, and if not, just hide the Remote HD button entirely, as I’d expected?

Lastly, it appears that “uninstalling” RemoteHD via the Maintenance menu doesn’t work properly either.  I mean, the button disappears from the Home Screen and you can connect via RemoteHD any longer, but Maintenance still lists it as “Installed.”  I had to fix this, somehow, by installing and removing it again via NitoTV.

So check this great app out, and be happy it’s available again… but tread carefully if you value a clean and sensible home screen on your AppleTV.

I just tested on a second AppleTV.  Firecore’s Maintenance menu doesn’t “uninstall” Remote HD properly there either.  So it’s a consistent, repeatable bug.  The Remote HD button is removed from the AppleTV’s home screen, but Firecore still thinks it’s “installed.”   So you can’t re-install it again, for real!

I’ve got the same problem here as well. Is there any ETA for when this may be fixed?

I’m not sure there is any need for a Remote HD icon to be shown in the first place, but for those who want to know what version they are running, then adding a Remote HD menu option into the Maintenance menu may be a better solution, but please not on the home screen as it’s absolutely useless there.

I would think it makes sense for the remote HD settings to be with the rest of the settings. No home screen icon at all. Is there somewhere else for us to post suggestions, or does the staff monitor these threads?

This issue is currently being looked into. An update shouldn’t be too far off.

Thank you James!  Looking forward to any new developments.

yes, thank you James. I always appreciate knowing when things are being worked on.

after installing this new Remote HD update an 4.3 atv2, my Atv is dead!

I can’t boot. I’ve no access at all.

Thanks mikey, but when I try that I get:

Reading package lists…

Building dependency tree…

Reading state information…

Package remotehd-atv2 is not installed, so not removed

0 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.

And Remote HD still appears as installed…

Hi James - Any chance you came up with a solution for this? 

And btw, thanks for all the hard work and the awesome software!


Seems like a good time to ask how much better the Remote HD is in comparison the stock Apple Remote App?


Not so much “better” as it is “different.”  It basically lets you share (VNC style) the AppleTV screen and it’s whole UI onto the iPad, while controlling it.  The stock Apple Remote app is wonderful and essential.  Remote HD is cool but for a different style of control.

Hi there.

When I removed Remote HD due to not wanting the icon on my home screen, I was struck with the same issue as others where it still said I had the app installed under the Maintenance menu.

Well, I haven’t figured out how to remove the icon from the home screen, but in order to update the menu under Maintenance I was able to re-install and then cleanly uninstall the app from Terminal.

What you need to do is SSH into the Apple TV and then run the following apt-get commands:

apt-get install remotehd-atv2

and then

apt-get purge remotehd-atv2

The purge option will basically remove the app and any configuration files that relate to it, which will clear the cache that Maintenance is looking at to check whether the app is installed.

I’m hoping that somebody at FireCore updates both the aTV flash software to correct this and the Remot HD app to remove the item from being on the home screen, but until then, the Apple Remote app looks good enough for me.

Enjoy :slight_smile:

Just to clarify. Is the Remote HD app actually working properly in terms of functionality?

And therefore the only issue people are having is to do with the fact that it puts an Icon on the Home Screen?

Yeah definitely the ugly home screen icon for me is the main concern.

Right, so, no issues of functionality?

(i havent installed it back yet since the last round of issues)

Thanks iJaffa. I’ll try that and let you know.


What happened to me is that the icon appeared, so I wondered what it was and clicked on it, then it froze my ATV. After removing it, I tried to uninstall Remote HD as the version was unstable, but while I got all the message confirming things went well, the app still appears as installed and I’m stuck there.

Right, so, it is still unstable? Or, it just becomes unstable after you click on the Icon… ?

couldn’t go far enough to find out.