Issues with Mac version of Seas0nPass

I had no end of issues and was never able to fully jailbreak my aTV (2g) running 5.3 on my Macbook, using Seas0nPass 0.9.4 (766).

When (and this was a rarity in and of itself) the Apple TV could be put into DFU mode, Seas0nPass would quit unexpectedly some times, and then other times it would make it 95% of the way through the process and I’d get the “Firmware restore failed?” error. I would even restore in iTunes to try and troubleshoot.

Fortunately I have a windows laptop handy. I’d read that some people had luck using the Windows version of SP. I tried and on my first time (i restored the aTV to factory settings first), it worked perfectly.

This isn’t proof by any means, but I think there’s some pretty convincing evidence that there are some serious issues with the Mac version of Seas0nPass. Hopefully there’s a fix on the way.

Just wanted to pass along my story.

Based on how well the Firecore folks did with fixing the same issues with 9.3, I wouldn’t hold out much hope that 9.4 will be handled any differently.