Issues since installing MacOS Mojave

I’m having issues connecting my Apple TV (jailbroken with Seas0npass, installed with aTV Flash) to my iMac since upgrading my iMac to Mohave. Best as I can figure out:

  • Mojave has automatically updated my filesystem from HFS+ to APFS, which means I can no longer share files using AFP (apparently it did this upgrade for some people with High Sierra, but not for me until now for some reason)
  • in the sharing settings on my iMac, AFP is either greyed out (no longer available as an option) or can be selected but doesn’t do anything
  • however for some reason I can’t connect from my Apple TV to my iMac using smb
  • I’ve used smb settings that work on Infuse on my phone - I can access my iMac just fine from there (iPhone 6S)
  • I’ve re-jailbroken my Apple TV and re-installed the latest version of aTV Flash that I could find on my account page (v2.6.1 created on Jan 19, 2018) - had to use my son’s laptop running High Sierra to do this, as it wouldn’t work on Mojave (long process and then an error saying it had failed)
  • when I enter the smb settings on the Apple TV and select test connection, I get a loading spinner and then eventually an error message: “An error occurred. Could not open directory [directory details redacted]…Reason: Operation not permitted” (exact same settings that work fine from my phone)
  • have tried alternating between computer name on network (for me, iMac.local) and the same with the filename added which I read somewhere can help (for me, iMac.local/AppleTV). The former works from Infuse on my iPhone, so it should work here. Nope.
  • sharing settings on iMac have “Share files and folders using SMB” checked, and I’ve checked the box allowing Windows File Sharing too.

So I’m at the end of the road I think…my best guess at this stage is that either the Apple TV 2 hardware or the aTV Flash software doesn’t support the latest version of smb, I gather my iMac uses smb 3…have tried other software on the Apple TV (Kodi v14.2 which wouldn’t fit on my screen and then froze, and Nito TV which kept crashing).

Any ideas?

I have the same problem here… :confused:

Hi, I guess the there is no way to jailbreak with seas0npass on Macosx High Sierra or Mojave.
I installed Macosx Yosemite on a 32gb usb stick, I boot from the usb and then Sea0npass works perfectly.

Seas0npass no longer updated for newest Osx


For years I’ve been successfully running aTV Flash from my late 2011 MBP (currently running High Sierra.) I recently acquired a iMac 21.5 (Late 2012) running Mojave.
I’ve followed the instructions (and matched those on my MBP) to create Shared Folders. After adding the iMac as a Share using the instructions - Basic Setup – Firecore - I test the connection and its passes. When I go to view “My Files” nothing is available or appears in the Library. I’ve gone back and set up the MBP and that proves to work and my Movies Folder appears in the Library.

I assume AFP is the correct Share Setting?

Any other thoughts on why I’m not seeing my Library?

I am experiencing the problems running El Capitan (the earliest OSX platform I have.) Yosemite was one version earlier. So maybe I have to find a way to go back to that.

I’m willing to bet the aTV2 doesn’t support the version of SMB being used on newer versions of OSX. You might have to look at setting up NFS (if supported) or installing SMBv1 support into MacOS