Issues installing adobe flash

Hi,

I have followed these steps: http://forum.atvflash.com/viewtopic.php?f=5&t=1850

I get an error message “Adobe Flash installation failed, popping controller in 5 seconds”

I noticed when I tried it a second time the CoreAudioKit.framework folder was removed from the /Documents folder on the AppleTV. I FTP’d it again and tried to install… same prob.

I noticed the log file:

2009-09-26 07:54:18.709 mHelper[210] Root filesystem already writable

2009-09-26 07:54:18.710 mHelper[210] mounting image: /Users/frontrow/Install Flash Player 10 UB.dmg
2009-09-26 07:54:20.898 mHelper[210] mounted: /Volumes/Install Flash Player 10 UB 1
2009-09-26 07:54:20.924 mHelper[210] removing file at /System/Library/Frameworks/CoreAudioKit.framework then install
2009-09-26 07:54:20.936 mHelper[210] copying: /Users/frontrow/Documents/CoreAudioKit.framework to: /System/Library/Frameworks/CoreAudioKit.framework

Any ideas?

BTW, I made the permissions on the CoreAudioKit.framework folder read-write by everybody in case it was a security issue.

regards

Adam

I haven’t checked my log, but I am having the same experience. I noticed in your log that the CoreAudioKit.framework was copied over to the System. Seems to me that the software is probably doing what it is supposed to be doing, but like you, my Adobe Flash installation keeps failing. Not mission critical yet for me, but I will want to be able to watch Flash-driven content before too long.

After not being able to stream certain URL contents, f.e. (http://mediathek-video.br-online.de/o16/br/b7/player/public/b7mediathek.html?bccode=bfs
I was guided to http://wiki.atvflash.com/index.php?title=Enable_Flash

  1. I used Pacifists “Open Apple Install Discs” on my old Mac OSX upgrade (Tiger) DVD.
  2. When extracting the file “CoreAudioKit.framework” I end up with a folder rather than a file which contains 1 alias (exec) file “Core Audio Kit”, 1 alias folder “Resources” and one folder “Versions”
  3. I moved the CoreAudioKit.framework folder to the Documents Folder on AppleTV.
  4. Although I had installed Flash priorly I again navigated to Maintenance > Install Extras and selected Adobe Flash
  5. A screen appeared saying something like "Dependencies installed, restart Finder? - Yes.
  6. Still - when navigating with CouchSurfer to the stream URL the Finder reboots

Is there anything I missed - could it be a problem that I am running OSX 10.6.1 and not Tiger on my Mac? As I read in another post:

Kind regards, Axel

PS: I also noticed

… when I tried it a second time the CoreAudioKit.framework folder was removed from the /Documents folder on the AppleTV. I FTP’d it again and tried to install… same prob.
and
…made the permissions on the CoreAudioKit.framework folder read-write by everybody

Same EXACT situation here. Did you ever find a solution? Firefox won’t install either.

Thanks!

Jim

getting the same problem after upgrading to ATV 4.0

I fixed it. I had to do a complete reset to defaults. Then did the 3.0 update. Then did the atvFlash 4.0. Then updated all plugins, apps, etc. It worked.

^^presumably you still had to add the coreaudiokit.framework files to your ATC though for this to work!?

You know, I didn’t even realize it, but no. I didn’t have to do that. I think the atvFlash installer now possibly downloaded it just like it downloaded the Mac OS X 10.4.9 Combo Intel installer. Earlier versions never did this.

I’m not 100% sure that the installer got it for me, but I am sure that I didn’t reinstall the coreaudiokit.framework files manually. None the less, Flash installed.