Issue with MKV files on Infuse Pro 6.1.7 and iOS 13.1 Scrubbing to end

I’m running the latest version of iOS (13.1) and Infuse Pro (6.1.7) at the time of this posting. I have multiple MKV files encoded in x265 attempting to play back on my iPad. I have some weird issues with video scrubbing (or attempting to make sure I can get to then end of the file).

iPad Pro 12.9 3rd generation (latest at the time of this posting)
WD My Passport Ultra 1tb USB (external SSD directly attached)

A) Using the files app, I’ll long press an MKV and then select “Open in Infuse”. The file will play normally but if I scroll the timeline to around the 4/5 mark through the video Infuse will pause for about 15-20 seconds, and then put me back to the beginning of the film. If I force close the app and try this over again, but move the timeline to a few minutes before the mark and let it play naturally it will stop at the same mark and go back to the beginning.
– Video is encoded x265 - Slow - CQ 22 - Handbrake
– To make sure that this file is not corrupt. I grabbed a fresh blu-ray mkv rip and did another x265 encode. Same issue.
– I also tried copying this file into Infuse and playing locally from the iPad. Same issue

B) Same as scenario A - I have many mkv files copied into Infuse that fail to scroll to the end or close to it from the beginning. I should mention that all of these play fine on VLC on the PC

C) Different movie than scenario A - Same behavior as before when on external storage, only this time when the movie is copied into Infuse it plays properly to the end. Same file has different behavior depending on where it is located.
– Video is encoded x265 - Slow - CQ 22 - Handbrake

I’m attempting to now use Handbrake’s built in Apple 2160p60 4k HEVC preset on the files in scenario A and B to see if putting this in a different container will help. I travel out of the country next week so any help you could provide I would appreciate it!

1 Like

Welcome to the forum, and sorry for the trouble.

Would you be able to upload one of these problematic videos we could review here?

Also, the upcoming 6.2 release will include a number of enhancements for accessing videos directly from USB drives.

I have already uploaded the file last week under my email address on file. Let me know if you need any more information.

Is the file larger than 4GB? It’s looking like iOS 13 has a bug with that and others are encountering it as well. Files larger than 4GB with directly attached drives or over SMB connections seem to have problems right now.

Have you tried playing it in VLC in iOS?

Not doubting you but could you cite an official source that confirms this 4GB limit?

I didn’t say it was a limit. It’s more then likely a bug. iOS 13 supports different drive formats that can work with files larger than 4GB. I cant really give a link to official documentation for something that is likely unintentional behavior.

There are other threads on this forum that have encountered this same bug. The Apple Files app is having trouble with files over 4GB through directly attached drives and over SMB shares.

Okay, other than a few posts here discussing a problem with a certain file type that happens to encountering issues in their playback in Infuse, is there any outside source relating this bug to the operating system? It the other thread the problem could be from several different areas since they are transferring files to an iOS device and results are inconsistent.

I was just checking your sources in case there had been a developers discovery of some bug in the new OS. :wink:

I wouldn’t know. I have not been looking too deeply into this and have not upgraded my iPhone 8 Plus or iPad Pro to iOS 13 yet due to it still having quite a few bugs. I use these devices a lot both at home and for work and this has prevented me from running tests my self. Though I did install iOS 13 for about a day on my iPad Pro before the bugs sent me running back to iOS 12.

I do really want to move to iOS 13 though. It has added several features I have been wanting for years.

If you are interested and happen to have iOS 13 installed, you could always try running some tests. So far from what I have seen there is a bug relating to files bigger than 4GB where direct access through Apple Files from either a directly connected drive or over SMB will not seek and/or play properly and also will not copy correctly to the device (through the Apple Files app).

Direct SMB access through Infuse to play and copy files over still works correctly even with files over 4GB. iOS 13 seems to still support files over 4GB, just not when accessed or copied through the Apple Files app. This is why I believe it’s simply a bug with the Apple Files app that has not been fixed yet.

As for different results for different people. It could be they just happen to be under the 4GB file size for the media they are using and have yet to encounter the bug. Or they could be accessing it through Plex or over SMB directly through Infuse like I tend to do.

THe files I have issues with are all over 4gb in size and your description is exactly what I’m experiencing

1 Like

Quick update on this.

We’ve confirmed this to be an OS-level bug that we can’t workaround on our end. :frowning:

The Files App appears to be using uint32 to address file data and thus can’t handle files larger than 4.2Gb. We’ve opend a radar for this, so hopefully it’s something Apple can address in the future.

1 Like

I am wondering if you guys have had any updates to this file size bug in iOS 13/Files.

This was fixed in a few iOS versions for me. Didn’t have any issues with larger MKV files anymore.

1 Like

Really? That’s great news! I’ll have to give it a try again.

Yep. Apple resolved this issue in iOS 13.2.

Nice to hear, that they resolved it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.