Issue with Media Player and large SMB shares

Hi folks,

I’ve been a happy user of aTV Flash for some time now, but today I came across a problem with the Media Player. I have an SMB share (for some reason, can’t get NFS to work in Media Player) called “movies”", within which I have two subdirectories: “Movies” and “TV Shows”. Both worked great until recently, when everz time I tried to open “Movies” I got an error saying that the SMB share doesn’t work. It clearly does, though, because I can open the SMB share and its subdirectory "TV Shows"without issue, it’s only “Movies” that doesn’t work.

Since the only recent changes were adding more stuff to it, I started debugging by moving things out of the subdirectory. Eventually I got it working, and came to the conclusion that if a given subdirectory has more than 490 objects in it (all subdirs in my case), I get this error. I also validated that it’s not an issue of a specific object (e.g., weird characters in names, etc.), because I can swap one object out and another in, and no matter which objects are left, it will work if <= 490 and won’t work if > 490.

This may not be an issue with Media Player itself, but perhaps an issue with aTV Flash, because XBMC also behaves strangely: even if the subdir has more than 490 objects, any previously scraped objects can be played back fine, but no new ones are discovered.

Have any of you had this happen to you? Do you think using NFS instead of SMB might fix it? If so, any idea how I can get Media Player and/or XBMC to allow me to map NFS shares? (I can map the NFS shares from other Linux machines in my network, but never from aTV.)



Hi Lbaca,

Sounds like a very interesting problem indeed. To make sure that everything looks A-OK software side, could you post all the current AppleTV version you are running as well as any other apps you have installed (like Maintenance, CouchSurfer etc…).


Also, when navigating your files, are you accessing or using the “Library” function at all?




After the holidays, an update or two of the software, plus some “out of space” issues being resolved, this problem ceased to occur.

I still can’t for the life of me connect to an NFS share that works from another client, but I guess that’s another issue…