ISO playback issue


I have just started using Infuse. Wow! Its what I have been waiting for. I have been long time user of My Movies due to the ISO rips of blu-rays in my library. I now have uninstalled My Movies and only want to use Infuse.

That said I seem to have encountered a rather strange issue when playing iso files.

While watching a movie at a specific time stamp the movie jumps to another title(chapter) without any selection.

Attached are two pictures.

Image 1 shows Title 139 checked off. The previous title 138(main movie) was playing and then all off a sudden when the main title reached a specific elapse time it switched to title 139. I can repeat this over and over by selecting title 138, then fast forward just before the specific time( about 1:06 into the movie) and it switches to title 139.
Image 2 shows a similar scenario except I selected title 130 to start. Then the same thing occurs when the title reaches a specific point it switches to title 134.

When infuse switches to these alternate titles I can’t advance to another that easily and once that title is over the movie stops playing completely.

This is happening with more than one movie iso file. One title I have the movie jumps to Color bars and test patterns.

These alternate titles seem to be additional content that the disc (iso image) has on it.

When using My Movies this never happened.In order to view this additional content I would have to navigate to it using the disc menu and manually select it.

These are full blu-ray rips so everything is available just like the original disc.

Also as the two pictures show there are two different main titles. One is title 138 (duration - 2:04:39) and the other is title 130 (2:07:28).

I believe title 138 is the main movie and the other title 130 is some interactive version with some strange graphic junk mixed into the movie.

Infuse seems to select the wrong title 130. Is this because Infuse selects the longest title and assumes this is the main movie? Is there a way to change this?

This movie is Iron Man 2.

In the movie folder is the iso file, folder art and a xml left over from MyMovies with the following title info:

<?xml version="1.0"?>


Ironman 2


I found this similar post but not exactly my situation:

And this also that touches on this subject:

I tried browsing the shared folder favorite and also the Library generated by Infuse. I get the same results.

I am continually updating this post. I am seeing this random of skipping titles in almost all my blu-ray rips so far. It seems that Infuse just can’t manage Blu-ray iso titles very well.

This is really discouraging. Unless the v5.6.8 soon to release addresses this.

Update : I updated the app to v5.6.8. Still seeing this title issue. Does anyone else see this?
I can’t believe it’s only my iso rips. These rips play with no issues when using Virtual CloneDrive and My Movies.

What is going on here?

Can anyone else confirm a similar issue?

Can I get some support please?



Waiting on some support with this. I tried the new v5.6.8. Still the same issue with random title jumping during the main title playing.

Any clues?

Did you make these ISOs yourself? If so, it may be good to try again with the specific ones you are having issues with. Ive never run into the problem of title jumping with any of the ISOs ive created. Infuse will usually select the “longest” title available, there are some quirks for sure, but 99% of the time, its worked correctly. The only time Ive had trouble is where Infuse selected the wrong title for discs that I didn’t create. In this case I just manually selected the movie track and it played as it should.

I created every Blu-ray rip myself years ago using anyDvd licensed copy. And like I mentioned I can play perfectly when mounted via virtual CloneDVD.

One of the additional issues is the fact infuse does pick the longest title. In more than a few instances that title represents a secondary take of the main title. Interactive version or narrated version and so on.
I have tried to reselect the correct title but then at a specific point in the movie infuse selects the next title that is listed after the main movie and breaks away from the current point of the main title playing this extra track.

Really strange. Especially when I can play the same iso image other ways without this happening.

Also thanks for your help!!!

I’m not sure there is a way to force Infuse to pick a different track, @james would need to answer that. The ones where I did have an issue, it picked a different track (no the longest), but those were ones I did not create myself. With those however, once the correct track was selected, I was good to go for the rest of the movie. It almost sounds as if for some reason Infuse is having trouble with your ISOs and its being forced to skip\jump tracks. One of the developers will probably be of more assistance as they may request you to send in debug logs.

We are looking into a few similar reports with ISO files that have come up, and hope to have more news soon.

Also, at this time Infuse will default to the longest available title. This covers most cases, but it seems not all. Our long term plans include a few ways of better handling track selection, though if I’m honest it will be a little while before we dig into that.

Yes that’s exactly what’s going on.
Infuse jump skips on its own. And does it at a specific point. I literally can’t watch the entire main movie title. Not all movies but a lot.

I just don’t see why playing the iso other ways I don’t have a issues.

If @james or any developer would get involved I would be more than thankful and helpful to debug this.

Understood. Thanks for the update.

@james Can you recommend some software I can use to delete the other titles from the iso file?

Eliminating the unnecessary titles will prevent the random skipping and keep the movie playing.

This isn’t ideal as I have many titles ripped to iso but moving forward it will allow Infuse to work better with my ISO’s. This is my main concern.

Thanks again.

Keeping this topic alive!

I am not James but I might help.

Some discs (especially animation, where parts of the video are language specific) have titles which are actually playlists.
I do not know a way to “delete” titles from an ISO, but there is an easy way of extracting the titles as they are meant to be played (the playlists used by blu-ray players).
You can use MakeMKV for that, available at

Hope this helps :slight_smile:

Thanks! I know about makeMKV. I don’t want to re-encode all of my movie library.

I will wait to see if a fix that @james promised might address my issues.

Otherwise ultimately I will be forced to make MKVs I guess.


@james My app updated to v5.6.9. I started to watch “The Other Guys” and several times the audio track stop playing randomly and a loud grableing(digital distortion) cut in. The only way I could get it to stop was to restart the Apple TV. But then it did it again and again after trying to continue to watch the movie. This didn’t seem to happen with the previous version. Although there are other iso supporting issues.

I love this app and want it to work right but I am wasting my time thinking ISO files are fully supported. THEY ARE NOT.

That said I am going to convert my movies to mkvs. The few movies I have converted so far from the same iso files that don’t play right do play well as mkvs.

Please remove this file as being supported as to attract more sales. It can cause damage to someone’s audio system with this new issue.

And to repeat myself none of these issues have ever occurred when using MyMovies that integrates PowerDVD as a player.

Every file always played flawless!!!

  1. you cant compare Infuse to something youd use on your PC.
  2. Did you try changing audio tracks to see if that resolved the issue? If so what where the audio tracks that were causing this “distortion”.
  3. Its silly to remove the listing of support when they ARE supported. There still may be bugs associated with playback, but this has no bearing on if the format is supported or not.

We have a few changes in-progress for ISO files that we believe will help with a few of the reported issue that come up.

Thanks for your patience.

@james, Just checking in with this subject again. Haven’t seen anything in any of the release notes over several updates that pertains to any ISO issues…

I realize the “iso file” subject isn’t particularly a high priority but is there any time line when some issues may be addressed?

It appears from reading other posts that there are more issues and I am not the only one with concerns.

Thanks in advance.

The changes are a bit far-reaching, and require a fair amount of testing.

As of right now, we hope to include these in the 5.7.1 update.