Is there a limit to how many files can be in a folder?

I am running Infuse & on a Apple TV. I use to play files on a local NAS drive

I have a Folder Named “U2” that has 25 sub folders that each contain a concert video

When I us Infuse, it says that this folder is empty even though its not.

Can you help me?

What type of connection do you have setup in Infuse (SMB, NFS, UPnP, etc…)?

If you browse this share via the Settings > Shares > Share Name menu do the folders/files appear there?


Yes the folders appear and there is content in all the folders except for the one folder I have with 25 sub folders

Do you folders have different permissions? Does the user you are logging in through Infuse have access to this folder?

As a quick test, can you try moving the content of this folder to another location that currently is visible in Infuse?

After you try James’ suggestion I have another question, this folder doesn’t by any chance have the word “extras” or “featurettes” in the folder name? Any chance you have a hidden “.nomedia” file in this folder?

I have a new issue. I cant connect to my NAS anymore, yet I can connect with VLC. I have set this up before so I thought it would be easy to just re-enter the information

But to answer your questions about the orginal problem, there are not special folder permissions set and there are none of those terms used such as extras or featuraettes. It is a folder called U2 and has 25 sub folders with various concerts in various formats.

Can you try connecting and if the error persists, send in a report from your device (and post the code here) so we can look into this?

My diagnostics code is TRH2N

Can you check to see which version of DSM you are running on your Synology server?

The 7.0.1 update includes some fixes for SMB, which were introduced in the 7.0 update.

I have 6.2.4 which is the latest for my model DJ213j as it say that I have the most current update

it should be noted that FTP doesnt work either, nor does NFS and everything worked last week

Also VLC player works and connects.

in addition to above, I can not get my ipad to connect along with my Apple TV and all were workng last week

We have a fix in the works for 7.3.3 to workaround an SMB-related bug that Synology introduced.

I think this will help with what is going on here.

thanks James.

BUt FTP used to work as well and no longer does. Will FTP work again with the fix and is the bug in FTP as well?

I bleive it was Firecore that was using FTP. I hope I am not confusing programs with VLC

I didn’t see any FTP connections in your logs, so I can’t say what might be going on there.

You might check to ensure the FTP server on your NAS is enabled. Restarting the NAS never hurts either.

Its enabled for sure. It used to work… and I double checked just now. NOt to mention other programs can conenct

Its the same problem as SMB and occurs both on my ipad and atv

Here is the log as I just tried to connect with my iPad to ftp


HI James,

Were you able to see the issue with ftp as well as smb from my log above?

I just find it strange that SMB ans FTP no longer work on multiple platforms (ipad and Apple TV(

Ok, tonight Infuse finally let me connect via ftp!!! Both on iPad and ATV

However, it still says there is nothing in my folder that has 25 sub folders (concert videos all in individual folders)

Can you please please please, help me with this? Synology is not blocking access to this folder and I can access all the contents with VLC.

Can you list the folder names which are inside this folder? Anything with special/weird characters?

The name of the folder is U2 and these are all the files inside it. Please see attached. I have other folders with folders that have “-” (hyphens) in them and they all work


Update - inside one folder was a file name with a strange character. Changed it and its fine now


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.