Is my software too new?

I’m just learning of the concept of breaking the Apple TV. I have a Version 2, model MC572LL/A but my software is version 6.2.1 - will I still be able to jailbreak it?

Yes, JB it to ver. 5.3