Is ATVFlash Compatible with 2.2 upgrade?

Can the patchstick (either 3.0 or 3.1) be applied to the newly released ATV2.2 software?
Any workarounds for Smart Install/Safe Upgrade to 2.2 otherwise?
Thx

Don’t Install NitoTV, mediacloud and couchsurfer and it is fine.

any way to mount network AFP drives for media browsing OTHER than NitoTV?
(since Nitotv does not work yet)