IPSW creation failed!

I Had this problem last night, what I did was exit seasonpass and then shutdown the computer, to get rid of ramdisk. i then tried again and the same error. i simply then deleted it and redownloaded it and it worked the first time. idk if that helps anyone but seeing as these people at firecore never want to help anyone i thought i would try.

Its such a pain in the ass! Works with 4.3 but not with 4.4.2 - stuck at “Creating ramdisk”. Is it really a Mac issue? Then it should be mentioned at the “Jailbraking instruction page” - I did spent a lot worthless time until I figured out that it simply does not work with the Mac. As I want to have the 4.4 features I will have to wait grmbl

any news about that problem? :frowning:

I tried and tried and it still does not get out of Patching ramdisk.  I removed the Virtual PC plugin, trashed it, quit SeasOnPass, trashed that, restarted the computer, downloaded SeasOnPass again, unzipped it, clicked Create IPSW and it still gets stuck at Patching ramdisk.  I have a 3.33 GHz Intel core 2 Duo IMAC running 10.6.8.  What do I do now or will it not work with a Mac which makes it useless… I just bought my AppleTV and only did so when I discovered aTV flash.  I will have wasted over $135 (including a micro USB cable)  So this had better work or i will be one pissed off customer.

Hi Everyone,

I was experiencing the IPSW creation failed too.  What I found the problem to be was that I was running Seas0nPass from an external drive and also the IPSW file was on an external drive.  Something wonky about the permissions when the files are not located on the “ROOT” drive that MacOS is installed on.  I don’t know why.

Anyway short story is that I copied both the Seas0nPass and IPSW to my desktop on my MacMini and ran the process from there.  Everything worked perfectly the first time I tried it.

I’ve asked the FireCore team to update the Seas0nPass instructions to suggest putting a note in the jailbreak instructions to put the Seas0nPass binary and IPSW file on the same drive that MacOS resides on to prevent permission issues.

Cheers!

In response to the last post, both Seas0nPass and the IPSW file are on the desktop of my root drive.  Has anyone using a Mac been able to get past “Patching ramdisk”???

After several days of trying all the different suggested procedures to fix this bug still get error message “this device not eligible for rebuild” 

Does Build 265, available from today, fix that problem? Did anybody succeed using a Mac?

please delete

Hi.  Just tried using Seas0nPass for the first time last night.  I got stuck on the “Patching ramdisk” issue.  I tried your suggestion in the quote below, and a few other things, but to no avail.   Got new any ideas for me???

Thanks,

Jim.

 

Easy Jailbreak For APPLE TV2 Black 

Hi everyone this worked for me the first time I tried it

(KEEP APPLE TV POWER CORD PLUGGED IN WHERE YOU WANT TO USE IT AND DON’T UNPLUG DURING THIS PROCEDURE)

1 Download the latest 4.4.3 (9A405l) IPSW from Seas0nPass

2 Connect Apple TV to your computer with an extended USB cable long enough to reach where you will use Apple TV 

3 Plug in Apple TV power cord

4 Open Seas0nPass and select Create IPSW while holding down Option Key

   Seas0nPass will look for latest IPSW 4.4.3 (9A405l) you downloaded in step 1

Seas0nPass will complete the jailbreak and restore process automatically through iTunes

After the restore is complete follow the steps for performing a Tethered Boot.

7 Unplug USB and Connect HDMI before the light stops blinking (no rush just don’t unplug power cable)

8 Complete set up choices Language, wi-fi, Home Sharing etc etc

9 Launch latest aTV Flash aTV Flash (black) 1.0 Now Available

Please let me know if this is helpful because I had tried every possible suggested procedure for several weeks only getting error messages so I tried my own Idea and this one worked for me on the first try.

OMG - what kind of product did I buy???

OK, until a few weeks ago it was beta  status, but now as V1 is released everybody should be able to use it.

Now, with iOS4.4.3 I finally got over the “Patching ramdisk” stumble-stone, but jailbrake fails anyway. Restore in iTunes can’t be finished.

@Woody B: You’re also working on a Mac? I tried your suggestion to keep the power cord plugged in during the whole process, but no success either :frowning:

 

Woody - just went through a 4.4.3 Seas0nPass update (via a Macbook Pro running 10.6.8) and it worked fine on the first try. I really wanted to move to 4.4.x to get the iTunes match service working as our iTunes library is on a laptop. Seems taboo to be running a tethered update, but my wife isn’t happy when music is unavailable, and I rarely have had any reason to reboot the ATV2. Here’s hoping the guys can figure out how to get us untethered. I have no doubt they’ll come up with something!

I feel for those of you who are struggling :frowning: Keep working through it and submit support tickets. Being a developer myself, I can tell you that you can only read so many forum posts, but all tickets get looked at and prioritized.

James,

I tried removing the virtual pc plugins but since upgrading to Lion I have difficulty finding library stuff. I am stuck with Seasonpass trying to jailbreak de ATV2 at patching the ramdisk.

Best,

Carlos

 

I’ll switch to a Sony DNLA box …

Thank you very much - this helps me a lot. Exactly this stopps my Jailbreaking - after removing and restart the machine everything works.

regards

Erich

Like several others in this thread, mine gets stuck at the “patching Ramdisk” step. I have tried most of the suggestions in this thread, to no avail. I’m running OSX Lion 10.7.2, and have downloaded all the latest software from Firecore. I’ve even tried running Seas0nPass in Windows via Parallels, which gets up to the point of starting iTunes to do the restore, but the restore fails every time. I’m beginning to think this was a bad purchase.

Upon looking into the SeasonPass log file (under the Help menu on a Mac) I found another wall SeasonPass was hitting for creating my ipsw file.

/Library/ScriptingAdditions/QXPScriptingAdditions.osax

This appears to be an old QuarkXpress script from 2006. I deleted it and restarted SeasonPass and it got over this problem, apparently created the ipsw file but now I’m running into problems with Apple not signing them. “apple is not signing, check what blobs cydia has”

Any help?

UPDATE - After I restarted the computer SeasonPass worked up until the “this ATV is not eligible” error message in iTunes. -Sigh- now to figure that problem out.

What version are you trying to flash? Apple has stopped signing 4.4.4.

This thread here http://forum.firecore.com/topic/7292 is the same tutorial as http://forum.firecore.com/topic/7279 (which was posted first) just is more detailed.

Thanks for the info matty, but I’m on a Mac so I guess I’ll just have to wait. I just got a refurbed ATV2 and it came with 4.4.4 installed. I’m not sure if I can go back to 4.3 and I’m assuming that the few days it would take me to figure it all out there will hopefully be a fix for 4.4.4 on a Mac.

(Actually, does anybody know if I can do the Windows fix via Parallels on the Mac?)

Thanks again.