[iOS/iPadOS/tvOS] Artwork and metadata are not being downloaded

Hey guys,

Been using Infuse for some years already, on all my Apple devices (iPhone, iPad and ATVs).

Yesterday i finally got a raspberry pi 4 and attached a usb 2tb HDD to make a small NAS for my movies and tv shows.

However, since this backend change, Infuse doesn’t seem to download artworks and metadatas anymore. I haven’t changed any preference in the app and this happens on all devices.

Before rpi i was using Windows/Mac (hackintosh) SMB shares from an internal HDD and everything was fine.

I already reinstalled the ATV app once and made sure i have metadata fetching turned on.

As i’m using the same network protocol, same network, literally only the actual device that creates the share changed (but still using SMB just like macOS and Windows)

Thanks

Is Infuse even scanning the new server? Does it show files but no metadata or is it showing blank for everything?

i can play the files, 4k ones with not even a stutter. the issue is that i have no artwork or metadata, just screenshots from the files and the filename.

before a lot of data was downloaded from imdb or such

here are 2 screenshots: in one the folder is shared by Windows, the other is shared by the Pi. i’m sure you can guess which is which.

the same app, SAME SETTINGS, SAME FILES, just switched folders/shares.

also, i forgot to say that the drive linked to the Pi is formatted as ext4 and on Windows is exfat

First, check that in “Settings” under “General” you have

“Metadata Fetching” turned “On”

“Embedded Metadata” is “Off”

i’ve already said i have these setup properly and using them like this for years.

Next, go to the “Library” window in “Settings” and see if it shows a “Last updated…” message below the total of movies, tv shows, and others. If not what does the message say?

Just trying to help and the way for me to do that is to make sure we’re talking about the same settings.

library is disabled for me, i don’t want those things, i group the files myself. when i open a folder, infuse will read each file and grab the metadata and artwork and cache it. it worked like this since forever.

i’ve already explained that i haven’t changed settings, only the device sharing the content.

i’m very technical and if i would mess some setting, i would’ve figure it out in the last 2h pulling my hair out in this weird situation.

LE: @NC_Bullseye thanks for trying to help so quickly

LE 2: it seemed to me to be a permission issue, however i can manually select metadata for files and delete them

When your in the “Filme” page on the iOS device what are your options when you press the three dots? Can you do a screen print with that open?

Looking to see if it’s set on “Use Local Metadata” or on “Use Online Metadata”

i have “Use local metadata”. i looked for minutes for some kind of online metadata toggle. however this is nowhere to be found and also never required before switching to the pi share

Can you try using the ‘Edit Metadata’ option on one of the affected files?

  1. This will allow you to select a movie/show name manually, which may be a workaround
  2. This will also reveal the actual name of the file Infuse is getting from the server, which may shed some light on why these aren’t getting matched

@james as i’ve said, i can manually do this and it will work but i was not looking to do this for each of the 400+ files i have, on each device i use infuse on.

i actually fixed it by reinstalling raspbian os + samba and using the same config for smb as before. i think it was some kind of permission issue on the raspberry pi side even tho i could copy/delete/edit files. fresh install and restoring from backup fixed it without changing anything in infuse (as i said multiple times, this wasn’t the issue).
if devs wanna check it out, i have a full sd card dump of the installation that rise these issues. let me know

tl;dr: it was a rpi/samba issue, a clean install fixed it. not a infuse issue actually even tho i could only observe a problem while using it

1 Like