Invalid Argument Error(22)

Hi,

I’ve just downloaded and installed atvFLASH on my jailbroken ATV2 (4.4.4, tethered JB with SeasonPASS). I have installed mediaplayer (had to try several times until it finally worked) and wanted to stream the content of my PC laptop and USB hard drive (both NTFS formatted) to the Apple TV via mediaplayer.

I have activated the file sharing option for both my hard drive (that contains movies inside individual folders)

The ATV sees my PC laptop computer, and in the settings of the Add share, the connexion test ‘passes’.

When I want to open the shared files (that ATV ‘sees’), I have an error message saying it failed to connect to smb files with an ‘Invalid Argument’(22) reason.

Apparently, it’s only a problem with PCs or the SMB , as the ATV can see my friends MAC AFP files.

 

 

Please help me

opened a ticket for this issue… drives me nuts !! I tried every possible sharing option on my PC (win XP) but so fqr no luck: shared folder are visible on ATV, but as soon as I try to open them, I get the Invalid Argument error.

please anyone help !

No one at Fire Core has helped solving this issue.

Because other PC users might have the same problem, below is what I did to do to solve the invalid argument (22) issue when trying to open a share created on XP:

Using Regedit, open or create the following DWORD registry key: IRPStackSize here:
HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters\IRPStackSize

(Capitals and small letters are important)
In the Value data box (decimal), type 15.

Restart your computer. Now mediaplayer should be able to open your smb shares and play your movies.