Invalid Argument (22) on SMB NAS Share


I have the latest beta (6)  installed on my ATV2 and the latest media palyer (0.7). I can browse to movies on my NAS and play movies but when I add the NAS location as a favourite to the Media menu and then try to select this menu item I get a message saying “Could not open dir (smb://MEDIA-NAS/Movies). Reason: Invalid Argument (22)”.

Can you help? I have no issues with XBMC but prefer the simplicity of the media player.


My problem might be related. After upgrading to AppleTV 4.3 (using the new version of Seas0nPass) and installing the new Media Player, I can’t add an SMB media source anymore. The same source (an Iomega NAS drive) was working before the upgrade. I get an “Operation timed out (60)” error when I attempt to test the connection.

Hi All,


Any ideas?




I’m seeing the same problem, using aTV 4.3 with the latest beta 6.  it wasn’t happening when i had only 2 files on the share, now I’ve added 8 more i have the problem.

when looking at setting, the ‘test connection’ still passes for the share, and I can navigate to other folders on the share (document, pictures etc) it is only the movies folder that has problems- could it be something to do with the automatic metadata gathering?


I deleted the share, and reconfigured it as an AFP share and now it works

XMBC did show the same error- so it may be the iomega SMB implementation on my NAS and not fire core

I have exactly the same problem. There is no way to add my Synology DiskStation DS210j which was working ok before upgrade to 4.3 (JB by seas0npass, ATV Flash black beta 6) Doesn’t work as SMB nor AFP There’s more - my ATV2 keeps loosing WiFi connection, and doesn’t remember my iTunes account. 

Any ideas what to do?

I have a different error, but I think it highlights similar networking issues.

The error is:

AFP connection failed: unreachable network or incorrect login/password

I receive this error whenever I try to access my shared hard drive (connected to a time capsule) for the first time after the AppleTV has been off or asleep. Going to a favourties bookmark in the Media menu says it’s unable to connect, manually retrying says the same thing, but if I wait a moment it becomes available and connects.

Not sure if that’s similar to what you’re experiencing. In this instance it’s like the remote drive doesn’t respond straight away so it gives up trying to connect and just declares it as an error.

Quite annoying because it confuses other casual users of my AppleTV who get a big error that leaves them thinking it’s busted.

I get the same message: “Could not open dir XXX Reason: Invalid Argument (22)” when trying to enter the folder… the second try does work!


does anybody have a clue?