Instructions on how to restore 4.4.4 on a 2nd gen Apple TV without jailbreaking?

After I have already ran SeasonPass and aTVFlash-black, what is the proper procedure for restoring the latest firmware (currently 4.4.4) without jailbreaking the Apple TV?

I tried restoring the firmware through iTunes, but ended up with an Apple TV stuck on the Apple logo.
If I run SeasonPass it does work, but either I have to restore 4.3 or I have to restore 4.4.4 and it’s then a tethered boot (which I don’t want).
I recently got a Google TV (Logitech Revue) and I no longer have the need to jailbreak my second generation Apple TV. 
Can someone post detailed instructions on how to restore 4.4.4 without jailbreaking?

Thanks! 

When you say you tried restoring, did you do it from a custom firmware (shift+click), or just allow iTunes to select the latest one?

I let iTunes do the work - should I try to download this one:

  http://appldnld.apple.com/AppleTV/041-3539.20111215.EQTW8/AppleTV2,1_4.4.4_9A406a_Restore.ipsw

then restore from iTunes using this custom firmware (shift+click)?  Will that work if I have the jailbroken 4.3 firmware installed through SeasonPass? 

emmanuelh.2, did that do the trick? I’m trying to do the same thing.