Instant Crash on multiple devices


Even though I don’t have a Plex share setup, simply tossing the Infuse folder (found in the path above) was sufficient to fix the problem. Fetching metadata no longer causes a crash, and everything sync’ed back from iCloud perfectly.


1 Like

Hi mdg,

glad I could help.

There might be a couple of redundant steps (belt and braces approach) in there but it is hard to diagnose those afterwards with no logs - it works at least.

1 Like

Thanks a lot!!! Your method is working!

Solution is working for me too on macOS. Any idea how to get this fixed on AppleTV too? (delete App + reinstall?)

Can you try this? I don’t have an Apple TV - it works and iPhones and iPads.

Not everyone having this issue is running Plex.

IMHO the issue has nothing to do with the source of your media files - Plex was just the method I’m accessing my media.

That’s why I wrote it should be applicable for any kind of network share.

What seems to be the problem is that the metadata database somehow got into a corrupted state and having an active connection to your media files instantly retriggers the indexing process and also syncing this state with iCloud - hence the revocation of your network share and iCloud Sync. (assumption).

I agree, just wanted to reiterate that since your solution tends to reference Plex (I understand it’s what you are using but others may not realize it may also be a repair for other connections)

Also, something happened to cause this corruption to start with and that is what really needs to be addressed or otherwise it could be a recurring problem requiring this fix over and over.

That is why I’m asking users that have this problem to report what message is showing when the crash occurs to help define the process that is causing the crash.

Thank you for clarifying - now we are on the same page.

I totally agree. It’s is not certain that this is actually fixing the problem or just delaying it.

Let’s call it a “temporary solution” for everyone that wants to use infuse without crashing for now, until james could investigate it further.

If the problem reappears, this thread will get active again pretty soon I guess.

1 Like

Thanks for your patience, everyone.

We’ve tracked this issue down, and it was related to some unexpected data Infuse was receiving when fetching info from TMDB.

We are including a fix in the 7.5 update (which should be available this week). If you want to get the fix earlier you can install 7.5 through the TestFlight link below.


I joined the Beta (thank you for the invite), and I ran into a critical issue: I cannot restore my Pro-purchase. I tried to restore my purchase on my ATV 4K (2021) and on my MBP M1 Pro.

App Store purchases won’t transfer to TestFlight, but you can select the lifetime license and you will not be charged.

7.5 should be available on the App Store very soon, once Apple approves.


If you have already purchased a lifetime option through the beta, shouldn’t you be able to restore that beta lifetime just so you can test the process? (I know I can just purchase it again but asking anyways.)

For the record, I wasn’t able to get pro yesterday in the beta, but I just did a restore in the beta app, and it worked :man_shrugging:t3:

Thank you for the lightning-fast response!
When trying to “purchase” a lifetime option in the beta version of the App on my ATV, I was promted with an error message regarding my network connection. After “purchasing” the same license in the beta version on my MBP, I was able to restore the license on the ATV without any issues.

1 Like

In-app purchases in TestFlight can be sort of flakey, but glad you got it working!


I really can’t wait anymore lol. Am I the only one?

Same problem for me.
On Sunday I added a new TV show. While refreshing the database the app crashed. After a restart, the update was still running, I could find it via the search function and I could also play it. Yesterday I added more episodes and wanted to do it again. Unfortunately the app crashed after a few seconds while playing.
Database is on the NAS, Apple TV, MAC and iPhone connected via SMB.All software is up to date.

Not long now :wink:


That’s a terrific understatement. I can’t restore my Pro lifetime purchase, neither on Mac, iOS or AppleTV. That should have been MENTIONED in TestFlight somewhere, to avoid discussing this. I’m understandably wary about getting accidentally charged $CDN129 for something I’ve already bought. Can you guarantee I won’t be charged again?

You’ll get a notice that you won’t be charged. The problem doesn’t happen all the time only occasionally.

Or you can wait for the public release of this version which should be very soon.