Instant Crash on multiple devices

Thanks for your patience, everyone.

We’ve tracked this issue down, and it was related to some unexpected data Infuse was receiving when fetching info from TMDB.

We are including a fix in the 7.5 update (which should be available this week). If you want to get the fix earlier you can install 7.5 through the TestFlight link below.


I joined the Beta (thank you for the invite), and I ran into a critical issue: I cannot restore my Pro-purchase. I tried to restore my purchase on my ATV 4K (2021) and on my MBP M1 Pro.

App Store purchases won’t transfer to TestFlight, but you can select the lifetime license and you will not be charged.

7.5 should be available on the App Store very soon, once Apple approves.


If you have already purchased a lifetime option through the beta, shouldn’t you be able to restore that beta lifetime just so you can test the process? (I know I can just purchase it again but asking anyways.)

For the record, I wasn’t able to get pro yesterday in the beta, but I just did a restore in the beta app, and it worked :man_shrugging:t3:

Thank you for the lightning-fast response!
When trying to “purchase” a lifetime option in the beta version of the App on my ATV, I was promted with an error message regarding my network connection. After “purchasing” the same license in the beta version on my MBP, I was able to restore the license on the ATV without any issues.

1 Like

In-app purchases in TestFlight can be sort of flakey, but glad you got it working!


I really can’t wait anymore lol. Am I the only one?

Same problem for me.
On Sunday I added a new TV show. While refreshing the database the app crashed. After a restart, the update was still running, I could find it via the search function and I could also play it. Yesterday I added more episodes and wanted to do it again. Unfortunately the app crashed after a few seconds while playing.
Database is on the NAS, Apple TV, MAC and iPhone connected via SMB.All software is up to date.

Not long now :wink:


That’s a terrific understatement. I can’t restore my Pro lifetime purchase, neither on Mac, iOS or AppleTV. That should have been MENTIONED in TestFlight somewhere, to avoid discussing this. I’m understandably wary about getting accidentally charged $CDN129 for something I’ve already bought. Can you guarantee I won’t be charged again?

You’ll get a notice that you won’t be charged. The problem doesn’t happen all the time only occasionally.

Or you can wait for the public release of this version which should be very soon.


This is happening to me too. Can’t manage to email a log before Infuse crashes.

This should be fully resolved in today’s 7.5 release!

Thanks for your patience. :slight_smile:


Thank you so much. Not only 7.5 solves the issue, but it also brought a feature I have been dreaming of for years :slight_smile: … don’t have to switch to YouTube and search for trailers anymore. I must say iI had a very pleasant surprise today. We tend as customers to complain and give negativ feedback when things don’t work as we expect, and we are slow to say when we are happy. So this time I wanted to be fast and say thank you. Good job!


Not in the Mac App Store yet.


Still not in the App Store, or showing up in Updates section. I assume this is an Apple delay? When do updates normally get processed and appear? It’s still frustrating to me that announcements are made for new versions that nobody can access (at least in the Canadian App store).

Yup, it’s an Apple issue.

Not much to do other than wait. I see the update for ATV but not Mac yet.

It’s usually pretty quick for everyone but we’re at the mercy of Apples servers updating.

And all of my ATVs are happily completing syncing now. Thanks James! :+1:

2 posts were merged into an existing topic: Apple store not updating to 7.5 on Mac Monterey

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.