Instant Crash on multiple devices

i just opened infuse, like i always do, but now it just keeps crashing. i have no idea what, how or why. this happens on all my devices (Mac, AppleTV, iPhone).

does anyone else have this issue? any suggestions? i reinstalled the app on apple tv, but it crashes the instant it opens. (all devices are up to date). it also crashes on iOS / iPhone when on cellular.
i have icloud sync on, trakt enabled (tried to disable it, no effect), and use mega for my file sync.

thanks for the help.

Two possible causes. Some issue with the connection to mega or your iCloud data was corrupted. Disable iCloud on any device that you can then try deleting the infuse iCloud data through iOS settings

16 posts were split to a new topic: Infuse Crashes on Apple TV

8 posts were merged into an existing topic: Infuse Crashes on Apple TV

Infuse us crashing on Mac M1 and Apple TV 4k. After start it continuously read storage and finally crashes.

1 Like

Same for me on all platforms (AppleTV 4k, macOS m1, iPhone 13).

It worked perfectly just yesterday!

It will always help to determine what’s going on if you include in your posts what version numbers of Infuse along with the version numbers of tvOS, iOS, and MacOS?

What protocol you’re using for the share like SMB, FTP, Etc.?

Does it crash as soon as you launch the app or does it take a little time?

1 Like

Yes, for sure. I thought that I’m not alone with the problem and it’s massive) Of course, I can provide details. It’s great that forum and tech support are so lively, kudos to you guys! :+1:

I haven’t had any problem with Infuse for about three years actually, happy pro user here :slight_smile:

Library is on Synology NAS 920+ with SMB protocol.
AppleTV (tvOS 16.3.2) was fixed with reboot.
iPhone 13 (iOS 16.3.1) with Infuse 7.4.10 was fixed after iOS rebooting and reinstalling of the Infuse app.

Can’t fix MacBook 13 Pro m1 macOS 13.1 (22C65). I have already rebooted it and reinstalled Infuse (7.4.10).
Infuse spins for about 1100 seconds, tries to update the library and crashes.

Translated Report (Full Report Below)

Process:               Infuse [6720]
Path:                  /Applications/
Identifier:            com.firecore.infuse
Version:               7.4.10 (7.4.4329)
App Item ID:           1136220934
App External ID:       854011024
Code Type:             ARM-64 (Native)
Parent Process:        launchd [1]
User ID:               501

Date/Time:             2023-03-10 02:08:16.9617 +0400
OS Version:            macOS 13.1 (22C65)
Report Version:        12

Time Awake Since Boot: 1100 seconds

System Integrity Protection: enabled

Crashed Thread:        7  Dispatch queue: FCOperationDefault (QOS: UNSPECIFIED)

Exception Type:        EXC_BAD_ACCESS (SIGBUS)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x000000016b9a3f60
Exception Codes:       0x0000000000000002, 0x000000016b9a3f60

Termination Reason:    Namespace SIGNAL, Code 10 Bus error: 10
Terminating Process:   exc handler [6720]
1 Like

I deleted everything and when I try to re add Mega it will crash.

I’ve updated macOS to 13.2.1 (22D68) and reinstalled Infuse. Nothing changed, crashes on macOS. I have no Mega, just SMB with local Synology NAS.

Same here. Worked fine a couple of days ago and now crashes repeatedly on my Macbook Air M1. No issues on AppleTV but I haven’t used it there in over a week, so will check that one too. VERY FRUSTRATING, PLEASE FIX IT!!!

Thia may help

Hello, first of all excuse me because the text is translated by my phone, I have the same problem, infuse 7.4.10 on apple tv 4k up to date and nas sino, closes after a while, I found when disabling the metadata update it works, I posted the same answer in the platforms section

1 Like

Infuse 7.4.10
MacOS Ventura 13.2.1 (22D68)
SMB protocol for the Share, (which has never given me any trouble before)

Takes about 1 min. before it crashes, could be while it’s updating metadata. I can send a system-generated crash repor if required.

Same issue. my crash is identical to yours.

C’est ca! La désactivation de la mise à jour des métadonnées est la solution.

DISABLE METADATA UPDATES AND THE CRASH DISAPPEARS. At least for me. Now we just need a fix for this instead of a workaround.

1 Like

What happens if you clear all metadata?

Well, I suppose you’d have none, and if you tried to re-enable it, it would crash again. I would say don’t clear the metadata yet til Firecore fixes this.

Hello everyone! I have the same crashing problem on all my devices (Mac and Apple TV) except my iPhone.
disabling metadata updates “fixes” the problem (only tried on my Apple TV… but I guess it will work on all devices).

Sorry for the trouble, and thanks for the reports.

We’re looking into what is going on here. Stay tuned.